1

I have a new hard drive with Mavericks, and I didn't have this problem on my old Mountain Lion install, so I'm sure there's some new setting somewhere I'm missing...

I have a lot of spaces open, and Google Chrome windows in all of them. I also have some Chrome windows minimized on the dock. Let's say for example that I'm in Space 1 using a Chrome window, and the minimized Chrome window was last active in Space 4. When I click the minimized window to open it, it animates up and fills the page in Space 1, where I am. Then it automatically moves the previously minimized window to Space 4. (So far, so good.) The problem? It doesn't automatically switch to Space 4. I'm still in Space 1, even though I clearly wanted to view the window I just un-minimized.

When I was using Mountain Lion, it automatically switched me over to Space 4. Any idea why this isn't happening now, and what I can do to fix it?

1

You need to go to System Preferences > Mission Control, and find "When switching to an application, switch to a Space with open windows for the application"

enter image description here

You need to check this box.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .