0

For some time I have been able to copy content from a web page and paste it into a Pages document and it would accept both text and images. But since the last update to Pages it will only display the text and if I want to include images I have to copy them and paste them individually.

Is there another way to do this that I am not aware of?

I am running Pages 5.2 (1860) on OS X 10.9.2

Thanks

2
  • Is it the same web content that you've tried copying and pasting now and before? It could be a problem with the content being coded differently instead of the Pages version.
    – Lizzan
    Commented Apr 30, 2014 at 9:34
  • Yes, it is. Please see my answer below.
    – forrest
    Commented Apr 30, 2014 at 14:09

3 Answers 3

1

It is often useful to sleep on a problem, or rather get some sleep after you ask the question. It came to me this morning that the problem might not be pages at all, but the browser. I have been using Chrome recently, so I decided to revert back to Safari to try the same process. I did the copy from Safari and pasted into Pages and the pictures came right in. It wasn't Pages after all.

0

Actually, it IS Pages - at least partially. If you create a new document in Pages and make sure the "Document Body" checkbox is checked in the Document section of the Inspector for the new document, the graphic will paste. (Note if you UNCHECK the Document checkbox, the graphic WILl NOT paste.)

The work around I use is to create a new document, paste into it, then copy it again in that document and paste it into the original target document.

It is a bug in Pages even if it is exclusive to content copied from Safari. It is also something Apple still needs to fix.

0

The following works from https://discussions.apple.com/thread/250452308

If you want to consistently preserve drag and drop links (and text), or those that are copied to the clipboard, then open a blank page in TextEdit (rich text mode), and select Edit menu : Substitutions : Smart Links.

Now when you drag/drop, or copy/paste from Safari, Firefox, or Brave, into TextEdit, all link information is preserved. It is a simple matter to drag/drop, or copy/paste this TextEdit content of the correct URL link into the Pages document with like effect.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .