7

My machine occasionally goes into a state where almost 100% cpu is eaten by syslogd and blued. At that time, numerous copies of the following block appear in the console:

4/29/14 10:31:45.000 AM kernel[0]: Item[208]: mID: 216  [0xffffff802ed70000]  OpCode 0x0401 (HCI Inquiry) from: blued (40)  Asynchronous  status: 0x00 (kIOReturnSuccess) state: 1 (WAITING) timeout: 43210
4/29/14 10:31:45.000 AM kernel[0]: mHCIRequestDeleteWasCalled = FALSE 
4/29/14 10:31:45.000 AM kernel[0]: expected events = kBluetoothHCIEventCommandStatus 
4/29/14 10:31:45.000 AM kernel[0]: expected explicit complete events = kBluetoothHCIEventInquiryComplete 
4/29/14 10:31:45.000 AM kernel[0]: possible intermediate events = kBluetoothHCIEventInquiryResult 
4/29/14 10:31:45.000 AM kernel[0]: or 
4/29/14 10:31:45.000 AM kernel[0]: possible intermediate events = kBluetoothHCIEventInquiryResultWithRSSI 
4/29/14 10:31:45.000 AM kernel[0]: or 
4/29/14 10:31:45.000 AM kernel[0]: possible intermediate events = kBluetoothHCIEventExtendedInquiryResult 

Any ideas what may be causing this and how to resolve?

8

Blued and syslogd are both daemon processes. Blued is your Bluetooth daemon process and syslogd is is your logging console daemon (crash reported, console log files etc). Blued is connected to your console daemon so I guess that blued is actually the cause of your problem while the syslogd issue is only a result of the blued's problems. Looking at the error it seem that there is an communication error and your blued process is just waiting for a response from a device. The error is that your blued command is your host communicator interface (HCI) and an request is send but without a response. It's weird that blued waiting from the kernel from a response it putting it in a 100% CPU state.

  1. Disconnect every bluetooth device in your device list and turn off every device that tries to connect to your Mac. Now re-connect every device again to your mac.
  2. Remove all bluetooth caches
    1. Turn off bluetooth
    2. Remove /Library/Preferences/com.apple.bluetooth.plist
    3. Remove ~/Library/Preferences/ByHost/com.apple.Bluetooth.*.plist
    4. turn bluetooth on again
  3. If you turn bluetooth off from the bluetooth menu, does blued eat less cpu? If you turn bluetooth on or off the blued keeps running. If the blued keeps running normal when bluetooth is turned off it could be an hardware issue
  4. Did you update the bluetooth firmware up to the latest version as well as your mac OS X software?

edit: option 5, it could be caused by cheap and crappy bluetooth hardware connected to your mac of course.

  • 2
    sudo pkill blued works to keep your battery alive while you fix the problem – Jason Pump May 13 '14 at 20:15
1

FYI, I tried this today and it did help with blued taking up a huge chunk of CPU time, but the ByHost .plists have changed in Mac OS X 10.9 and now Bluetooth is capitalized, ie: ~/Library/Preferences/ByHost/com.apple.Bluetooth.hhhhhhhh-hhhhh-hhhh-hhh.plist (h is hex values)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .