35

You know how when you disconnect from a VPN, you get a little scrolling "Disconnecting..." notification in the upper right notification area?

enter image description here

Well, I'm getting that, but it never goes away. It's been "Disconnecting" now for 20 minutes. The VPN is not, actually, connected anymore, but the UI won't let me reconnect now.

The Network preferences panel shows the same problem:

enter image description here

The console shows that the disconnect did, actually, happen:

enter image description here

Somehow the only problem is that the UI is convinced that I'm still disconnecting, which makes it impossible to connect again.

6
  • Any exciting log output in /Applications/Utilities/Console.app? Click on "All Messages" in the left hand Log List (Click 'Show Log List' if you don't have a left column) and use the filter box in the top right for perhaps either "VPN" or "racoon"? Apr 26, 2011 at 23:00
  • Nothing unusual there (I took a screenshot of the console log)
    – Joel Spolsky
    Apr 27, 2011 at 14:31
  • Perhaps just the menubar icon has just 'froze'. Try (re)moving it by holding down command and dragging it, and perhaps re adding it?
    – Josh Hunt
    Apr 28, 2011 at 1:07
  • I'm having the same issue. I have a lot of tasks/programs running and would love to avoid a restart. Anyone find a way to resolve this without restarting?
    – user9730
    Aug 11, 2011 at 15:12
  • 1
    Years later, same issue on macOS 10.12. Tried killing all the things, not much success.
    – Henrik
    May 31, 2017 at 11:49

10 Answers 10

32

If you're using a PPTP VPN, try manually killing the "pppd" process.

sudo killall pppd

If that doesn't solve it, you may need to add a -9 to forcibly kill the process. You should try without first though.

sudo killall -9 pppd
7
  • this looks promising, it is a PPTP vpn. I will try it tomorrow when I get back to that machine.
    – Joel Spolsky
    Apr 27, 2011 at 3:19
  • Nope. pppd was not running.
    – Joel Spolsky
    Apr 27, 2011 at 14:31
  • Thanks @kiboflavin. I had the exact same problem (with pppd running). That did it for me! Thanks Joel for having this problem before me. You're helpful is so many ways.
    – z5h
    Sep 15, 2011 at 14:37
  • 3
    This fixed the problem for me.
    – kolrie
    Aug 2, 2012 at 15:55
  • 1
    I was able to kill pppd only with sudo kill -9 pppd which is unsettling. Perhaps I wasn't patient enough with the regular kill. But if this is really what it takes, that's unsettling, and basically indicates that pppd is buggy. For what it's worth, I also tried disabling (not removing) the service in Network Settings, then reenabling it, as suggested by @KyleCronin, but it just brought back the scrolling "Disconnecting..." message.
    – tripleee
    Oct 27, 2014 at 15:24
3

Try killall configd.

After this you may need to sudo killall SystemUIServer.

(thanks, Avner. I haven't verified this. Please upvote if it helps you).

1
  • 1
    Nothing else did, but this worked for me (I did it in combination with the "make service inactive" suggestion in another answer). May 8, 2012 at 5:36
2

Try manually killing the "racoon" process, either through Activity Monitor or by running:

$ sudo killall racoon
1
  • hmm, no "racoon" process running.
    – Joel Spolsky
    Apr 26, 2011 at 19:52
2

What is the status shown in the Network pane of System Preferences? You can connect and disconnect your VPN from there. Re-opening the connection from there my resolve the problem. You can also toggle the visibility of the VPN menu from that pane, and see if that helps.

1
  • Nope. In that pane it says Disconnecting... and the connect button is disabled.
    – Joel Spolsky
    Apr 26, 2011 at 21:53
2

The SystemUIServer* process runs most of the stuff in the the menu bar. Kill it and it may solve your problem if it's just a UI glitch and not something deeper.

killall SystemUIServer

* /System/Library/CoreServices/SystemUIServer.app/Contents/MacOS/SystemUIServer

1
  • I think it's something deeper, since it shows that way in the Network systems preference panel.
    – Joel Spolsky
    Apr 26, 2011 at 21:56
1

I've managed this by creating two different "Locations" in System Preferences > Network. One of them (named "work") includes the VPN connection and the other ("home") does not. Switching locations while the VPN is stuck "Disconnecting" resolves the problem for me.

Incidentally, I've also configured the "home" location to use a static IP address and port-forwarding to improve my legal peer-to-peer filesharing experience.

1
  • Wow, even that didn't work for me. :(
    – Joel Spolsky
    Apr 26, 2011 at 21:58
1

Maybe you could try deactivating and reactivating the service. In the Network section of the System Preferences, select the VPN, click the gear logo at the bottom of the list, and click "Make Service Inactive":

enter image description here

Then do the same thing again to reactivate it and see if it works.

3
  • 1
    Nice try! Nope, that made no difference... it came back still "Disconnecting..."
    – Joel Spolsky
    Apr 26, 2011 at 22:54
  • @Joel I assume you've tried rebooting the entire machine? What about removing the VPN and adding it back again? Apr 26, 2011 at 23:02
  • 4
    I am certain that rebooting will fix it, so I'm actually NOT rebooting so that I can try every suggestion that comes up here, in hopes of finding a solution for this, you know, for the Internet
    – Joel Spolsky
    Apr 27, 2011 at 3:18
1

I've had this happen to me in the past, and if I remember correctly the only way to get rid of that was deleting the VPN entry with the minus sign, restarting and adding it back.

1

While holding the -key, try dragging the VPN icon off of your menu bar.

2
  • Still can't reconnect if I do that.
    – Joel Spolsky
    Apr 26, 2011 at 21:56
  • This just removes the "Disconnecting..." message. If you try this and then check the "Display VPN Status in Menu Bar" option in Network Settings to bring back the indicator, it will also bring back the "Disconnecting..." message.
    – tripleee
    Oct 27, 2014 at 15:28
0

You should check if restarting your computer helps.

3
  • Nope, that didn't help.
    – Joel Spolsky
    Apr 26, 2011 at 19:54
  • From the beginning of Mac OS X, Finder doesn't handle anything but displaying folders. You can even quit it (using various techniques) and everything will continue as normal, just without any Finder windows or desktop icons. Restarting the Finder is highly unlikely to have any effect on anything but the Finder's own windows.
    – Kevin Reid
    Oct 16, 2011 at 13:03
  • For the record, this suggestion was originally "Restart Finder". I suppose it's too late to flag the over-enthusiastic edit for a rollback.
    – tripleee
    Oct 27, 2014 at 15:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .