2

While attempting to remove a boot camp partition with Boot Camp Assistant I encountered an error. Boot camp assistant gave me an error message along the lines of "An error occurred while restoring the disk to a single partition." So, I backed out and attempted to try again. But, now when I try to use Boot Camp Assistant again and select the add/remove a partition function, Boot Camp Assistant tells me that I don't have enough space to create a partition. In Disk Utility the bootcamp partition is also not visible, only the Macintosh HD disk is visible, yet the Macintosh HD drive is still the same size that it was before I attempted to remove the partition.

So, neither Disk Utility or Boot Camp Assistant seem to be able to "see" the windows partition that I would like to remove, yet the space taken up by the windows partition has not been given back to the Macintosh HD partition. Anyone know how to fix this issue?

I'm on a mid-2010 MacBook Pro running Mavericks 10.9.2

  • Stack overflow doesn't let new users answer their own questions. Here is the solution: I was able to solve the problem with Disk Utility. I selected the disk in the pane on the left ("320.7 GB Hitachi ...", NOT "Macintosh HD") and then selected the Partition tab. In this view there is a Partition Layout diagram that showed the Macintosh HD partition taking up on 240 GB of the whole, while the bottom 80 GB was gray in color and not part of the partition. So, I dragged the Macintosh HD partition to fill the entire space and applied the changes. This seems to have solved the issue! – user76841 Apr 27 '14 at 23:06

You must log in to answer this question.

Browse other questions tagged .