0

I have a usb disk with two different partitions, one for TimeMachine and the other for storage formatted as NTFS.

This morning i was looking for a way to mount in r/w mode the NTFS partion (macfuse and "ntfs for macosx") but something gone wrong and my partition is not more mountable. Diskutils show the partition as "ExFat" but I'm 100% sure that is a ntfs partition.

There is a way to restore the partition type to NTFS?

enter image description here

  • I was originally going to suggest changing the partition type from that of NTFS to that of ExFAT (using, eg fdisk), but I see that both use type 07. Can you try removing all of the MacFUSE components and see if that helps at all? – mjturner Apr 27 '14 at 17:02
  • ExFAT and NTFS share the same type, you caught the point. I've removed all macfuse and other tools, but nothing changed. My last option was installing paragon ntfs and "magically" the partition shows up after the restart. Of course I didnt'loose any data :) – Ignazio Calò Apr 27 '14 at 19:24
1

ExFAT is not the same as NTFS, it is however cross-compatible with Mac (10.6.5+), Linux and Windows (may require additional drivers/software).

It seems as you have unintentionally formatted your NTFS-partition to an ExFAT partition, and depending on which version of OS X you're running your Mac can only read from that file system and not write. (Unless you have additional software installed to handle that file system)

You can try and reformat the partition in Terminal in case the Disk Utility is being silly, you will lose all files from that partition (they're technically not gone, but you'll need third-party software to restore them).

To format the partition open up the Terminal App and run:

sudo diskutil list

Find the partition that matches your USB-partition you wish to format. It should looks something likes this (This is from my own harddrive). Find the correct identifier for the ExFAT partition.

image

Now run the following in the Terminal:

sudo diskutil eraseVolume {FileSystem} {Name} /dev/diskN

Replace {FileSystem} with HFS+ or similar (only natively supported on Mac, not Windows/Linux) and {Name} with a name for the partition. Replace /dev/diskN with the identifier for your ExFAT-partition. Make sure you type the right identifier, if you type in the wrong one you could easily wipe your Mac's internal harddrive.

Now the partition should be reformatted, unless any errors occured. Now you can open up Disk Utility and choose to format the partition as NTFS if you don't want to stick with HFS+.

This might not be the most effective way to do it, I'm no expert so anyone with better knowledge feel free to come up with a more effective solution

  • 1
    I forgot to say that losing data is not an options ;) Thank you for the answer, I solved, read the comment. – Ignazio Calò Apr 27 '14 at 19:22
  • Glad you got it working! @IgnazioCalò :) – ebq Apr 27 '14 at 20:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .