2

I've been fighting this for months and I can't seem to get it to sleep consistently. I've talked to Apple Support on the phone and they couldn't help me. I've taken it in and he guy got it to sleep but shortly after leaving, it did it again...

I've run pmset -g after several attempts to get it to sleep and the following are reasons why it fails:

sleep                10 (sleep prevented by backupd-helper, powerd)
sleep                10 (sleep prevented by apsd, powerd, powerd, backupd-helper)
sleep                10 (sleep prevented by Google Chrome, Google Chrome)
sleep                10 (sleep prevented by apsd, powerd, backupd-helper)
sleep                0 (sleep prevented by coreaudiod)

As you can see, every time is a bit different but the culprits are generally the same. A full pmset -g reads:

Active Profiles:
Battery Power       -1
AC Power        -1*
Currently in use:
 standbydelay         4200
 standby              0
 womp                 0
 halfdim              1
 hibernatefile        /var/vm/sleepimage
 gpuswitch            2
 sms                  1
 networkoversleep     0
 disksleep            10
 sleep                10 (sleep prevented by backupd-helper, powerd)
 autopoweroffdelay    14400
 hibernatemode        3
 autopoweroff         1
 ttyskeepawake        1
 displaysleep         10
 acwake               0
 lidwake              1

and a pmset -g assertions

4/27/14, 4:06:16 AM CDT
Assertion status system-wide:
   BackgroundTask                 0
   PreventDiskIdle                0
   ApplePushServiceTask           0
   UserIsActive                   1
   PreventUserIdleDisplaySleep    0
   InteractivePushServiceTask     0
   PreventSystemSleep             0
   ExternalMedia                  0
   PreventUserIdleSystemSleep     0
   NetworkClientActive            0
Listed by owning process:
   pid 46(hidd): [0x0000000a0000126e] 00:37:52 UserIsActive named: "com.apple.iohideventsystem.queue.tickle"
    Timeout will fire in 594 secs Action=TimeoutActionRelease
Kernel Assertions: 0x4=USB
   id=501  level=255 0x4=USB mod=4/26/14, 4:21 PM description=EHC2 owner=AppleUSBEHCI

For a while it seemed that when my external monitor was connected, it wouldn't sleep but it happens also when my monitor is not connected. I've got it configured to go to sleep when my monitor is connected via the command sudo nvram boot-args="iog=0x0" as I find it annoying to have to unplug my monitor when I want the laptop to go to sleep.

I've reset both the SMC and PRAM, which neither have helped. I've reset defaults for Energy Settings and unchecked allow incoming connections. I've even shut down nearly everything running and it just won't go to sleep! I usually have to shut down the laptop because I've gotten home from work before to find my laptop running quite hot from just closing the clamshell and heading home.

  • how long was your sleep set to – Ruskes Apr 27 '14 at 10:15
  • Have you tried quitting or disabling the processes actively stopping sleep? apple.stackexchange.com/questions/92214/… – Graham Miln Apr 27 '14 at 15:21
  • @Buscar웃 my sleep was set to 5 mins but after resetting defaults it went back to 10. – Beshoy Girgis Apr 27 '14 at 22:44
  • @GrahamMiln I'm not sure that it's a good idea to disable all of these services, they seem like core services -- I'd really rather not have to disable everything just so the laptop would go to sleep if I can avoid it. – Beshoy Girgis Apr 27 '14 at 22:45
  • One at the time: backup helper--- Your backup destination is not mounted. If you don't intend to back up regularly, I suggest you turn TM off in the preference pane. You'll still get local snapshots. Turn TM on when you're ready to back up. – Ruskes Apr 27 '14 at 22:59

You must log in to answer this question.

Browse other questions tagged .