4

I have a WD external HDD which is plugged into my MacBook Air more or less all the time; it has two partitions one of which is my Time Machine disk. Just today I noticed that the hard drive is not mounting correctly anymore

  • On boot-up, both partitions do not show up in the Finder at all

  • When I unplug the drive and replug it back in, only the non-Time Machine partition shows up in Finder. It appears to work like normal i.e. reading and writing (I've already copied all my data off it)

  • I can't seem to either eject the disk or unmount the partition that is mountable. If I hit the eject button in Finder, the partition name greys out and is not clickable but does not go away.

Via Disk Utility, I am unable to either mount the Time Machine partition (I get the generic not able to mount partition error message) and I am also unable to run Repair disk on it (error message: Disk Utility can’t repair this disk. Back up as many of your files as possible, reformat the disk, and restore your backed-up files.). Screenshot below. I tried erasing the disk but that also did not work (error message: Couldn’t unmount disk.)

Disk Utility - Repair Disk

It sounds like my hard drive has failed (or is in the process of failing) - the only things that I makes me second guess myself and make me wonder if the disk is salvageable are:

  • The non-Time Machine partition appears to mount correctly and can be used as usual (although as mentioned above it cannot be unmounted)
  • The drive is not that old all: probably about 18 months old. I have drives that are older that are still ticking along nicely.

Is this a simple case of a failed drive (perhaps a defective product) or is this a symptom of a software related problem (e.g. there have been several instances where the drive has been unplugged without being ejected correctly)?

2

I would guess it's most likely a logic corruption/error and not a physical corruption of the drive since the other partition seems unharmed. This has a chance of happening if you are writing/reading data and suddenly unplug your drive. Can't be 100% certain so if I were you I would definitely try to backup the other partition to another drive in case it fails as well.

(If you could post a picture of how the drive appears in Disk Utility it would be great!)

WD has a 3(?) year warranty (you can check the warranty status of your drive here) on HDD's that suddenly fail which would cover a manufacturing error.

Before going through the tedious RMA process I would try to:
1) Unplug the drive
2) Reboot the Mac (without the drive connected)
3) Connect the drive
4) Open Disk Utility again and try to repair/fix the partition
5) Run sudo diskutil verifyVolume /dev/diskN (where N is the volume name not the disk name) to try and see if the file system structure can be read at all.

6) Depending on the outcome of the command (it should return something like "the volume X appears to be ok" if it's fine) I would try to repair it with sudo diskutil repairVolume /dev/diskN

7) As a last resort, run sudo diskutil eraseDisk {Format} {NewName} /dev/diskN (replace {Format} and {NewName} with your preferred file system and new name for the drive) which will try to erase the disk and apply a new file system. This will remove your previous partitions and you will lose the data on the disk.

If I'm being stubborn I would try to find a good disk repair software and run that to diagnose the drive before doing the RMA-process.

  • Thanks! I've added the screenshot and ran through the steps you suggested. Not looking good though: the distil commands all yield the error message: POSIX reports: Exec format error. I'll try and contact WD to see if I can get it replaced (which would be a bonus - I expected to have to write it off). – jpoh Apr 28 '14 at 8:42
  • I was in the same situation. Disk was still (physically) fine but I found no way to fix the partitions, so i had to erase it and start a new backup from the beginning. – maggix Jul 28 '16 at 6:38
2

I had the same problem and resolved it like this.

  1. Unplugged the drive
  2. Turned off Time Machine in Pref
  3. Rebooted the Mac
  4. Plugged the drive back in
  5. The Time Machine partition mounted
  • For me step 6 was to enable Time Machine backups again and then everything was back to normal. – Florin Sep 19 '16 at 18:06
0

So the drive turned out to be alright but Disk Utility was not able to rectify (and exhibited the symptoms listed above). I managed to salvage the drive by erasing it using Disk Management on Windows (where both partitions showed up as 'Healthy') and reformatting it on the Mac.

0

I rebooted the iMac and replugged the WD Time Machine 3 times --it would not mount and "could not be found". Wondering if it simply might be the cable connection I twisted the cable so I could insert the plug into its reverse position. It immediately mounted as it should as the lighting bolt plugs are reversible. Perhaps it was just a bad connection on a pin in the plug. Might need a new cable.

0

I had the same problem with my year-old external drive (3 TB Macbook) – the Time Machine partition wouldn't mount, and the other partition was fine but wouldn't eject.

Ended up reformatting the drive using a different computer (which read both partitions as "healthy"). Works fine now, though I wish I'd known and tried some of the sudo commands first! Wonder if this is something happening in Yosemite/El Capitan; never had this problem previously.

0

The Time Machine partition was not being recognised but the non-time machine partition was being recognised. I couldn't repair or even erase/reformat the Time Machine partition through Disk Utility as it just didn't recognise it.

I then split the non-time machine partition into 2 separate partitions with the intention of using one of them as a new Time Machine partition. However once the partition had been completed my mac then recognised the old Time Machine partition and everything worked as normal from then on - no idea why doing the additional partition solved it, but it did!

-1

just install the DiskDrill application then connect that HDD(which faces the problem) to your macbook and open DiskDrill application which is in your applications folder on your mac after opening it starts loading your drives then while loading external hdd in this application there is a possibility that this application can detect your problem and after correcting problem mount your disk on your macbook it seems like it unlocks something.

just try this application rather than trying too much commands its 90 % guarrenty that you can resolve your problem using this application.

if loading does not solve your problem then just go ahead and click on rebuild partition in this application.

steps :

  1. install DiskDrill application.
  2. connect HDD(which facing problem) to your mac.
  3. open DiskDrill application.
  4. after opening this application it starts loading your drives.

while loading there is possibility that this application can mount the unmounted drives. if not then

  1. wait for load and click on rebuild partition.
  • 1
    Welcome to Ask Different. To make your answer easier to understand you should use proper grammar and punctuation. As it's currently written, it's not entirely clear. Please see How to Answer for info on providing answers on this site. – fsb Feb 16 at 19:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .