1

I use Wireshark and it runs under X11 environment I want take some screenshot from wireshark windows but cmd + shift + 3 or cmd + shift + 4 or ... didn't work there is there any way that I could take some screen shot in X11 environment?

  • What do you see when you cmd shift 4 and selected the region? – ConstantineK Apr 26 '11 at 18:21
  • @hobs when I press cmd+shift+4 it types $ in wireshark search box. – Am1rr3zA Apr 26 '11 at 19:37
  • Is Aqua window manager still running or are you in a non-default X11 mode different than simply firing up the standard X11.app after a normal user log in to OS X? – bmike Apr 26 '11 at 20:59
  • @bmike I don't know what you mean by Aqua windows manager, if you mean the X111 grey windows, yes it runs and wireshark run within it. – Am1rr3zA Apr 27 '11 at 7:44
1

Click to the desktop or any other application, and then press + + 3.

With this method Wireshark will loose the focus and you can grab the whole screen.

  • there is no desktop when you cmd+tab to wireshark you go to another envirinment (X11) and if you want click desktop must switch to another application then your solution is useless for my case. – Am1rr3zA Apr 26 '11 at 20:15
  • Not true, resize your wireshark window to have a little smaller and then you can click on the desktop, or use Expose to show the desktop click on it and use Expose to show your application again. I did it and it worked. – KARASZI István Apr 26 '11 at 20:32
  • I don't know how you can do it because when I want run wireshark first it rum X11 (a grey environment) then run wireshark into X11 so when I minimize or resize wireshark I just see X11 Grey environment and can't resize it (or minimize) – Am1rr3zA Apr 26 '11 at 20:42
  • On the download page you can download Wireshark images for OSX which starts X11 automatically and runs almost like a normal application. – KARASZI István Apr 26 '11 at 21:36
  • 2
    If you're seeing "a grey environment" whenever X11 starts up, then X11.app is running in full screen mode. Press Cmd-Opt-A to toggle that, then you should see Wireshark running as a regular window on your desktop, and the other screen grabbing suggestions here should work fine. – calum_b Apr 27 '11 at 12:43
1

Have you tried using Grab.app? It supports a "timed screen" capture mode. You'd switch to Grab.app, select "Timed Screen..." then switch back to X11. After 10 seconds it will do a screenshot.

0

According to @calum-benson's hint, I found what my problem was. I must un-check 1Full-screen mode1 in X11 Preferences.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .