3

There is a MacBook Pro from 2012 with Mountain Lion that won't boot. The Apple logo is showing, the spinning wheel and then it just goes to a solid grey screen.

  • I've tried to hold Cmd+R while booting, this does nothing.

  • I've tried to hold Shift while booting, this goes to a solid blue screen

  • I've tried to hold Cmd+Option+R while booting, this does nothing either.

I'd rather not re-install OS X. Do I need to reset the NVRAM?

  • You can try resetting the NVRAM (⌥⌘PR until second chime) but if that doesn't work, try a verbose boot (⌘V) and see what it says. – grg Apr 26 '14 at 19:20
  • What does a verbose boot do exactly? – JNevens Apr 27 '14 at 7:19
1

I would recommend following Apple's guide regarding the gray screen at startup.

Have you installed any new firmware/drivers or software that might be the issue? Worst-case scenario is a re-install I'm afraid.

2

Try to do a file system check via single user mode.

  • Reboot and immediately press Cmd+S
  • Wait for the command line and then type /sbin/fsck -fy
  • Have a tea. And a cookie.
  • Have a look in the output. If the HDD is failing you might see something like I/O Error. If you see something like ***** FILE SYSTEM WAS MODIFIED ***** then you can try to do it once more. If Volume X appears to be OK then you might be lucky.
  • Type reboot and let it boot.

More info on apple's website.

Good luck!

2

I've just recovered a Macbook (OS X 10.5.2, Leopard) which failed to boot because it got eternally stuck at a grey screen with an Apple logo and a spinning wheel. The culprit was a corrupted configuration file (/etc/authorization), and below I'll describe how I found and resolved the issue.

First, I checked whether the hardware was okay, by rebooting and pressing D to run hardware diagnostics. The hardware was fine, so I continued to look for error messages.

After booting in Verbose mode (Command (⌘) + V), I saw that securityd crashed, and that a crash log was written to /Library/Logs/CrashReporter/securityd_2015-06-23-120634_localhost.crash. So once again I rebooted to get a shell in Single user mode (Command (⌘) + S). The log showed that the crash was caused by a call to CFDictionaryContainsKey (which triggered an EXC_BAD_ACCESS error). This fed my suspicion that the crash was caused by a bad configuration file.

I eventually came across this blog post, which suggests to use fs_usage to monitor and log the file activity:

mount -uw /
fs_usage > /var/log/fs-usage.log &
exit

After restarting, I looked in /var/log/fs-usage.log and found that securityd accessed private/etc/authorization before crashing. Then I viewed the content of /etc/authorization, and it was indeed broken beyond repair.

To recover this file, I searched for the original version of the file in the source of the securityd package (referenced at OS X 10.5.2's source code). I eventually found etc/authorization.plist, which had some similarities with the corrupted /etc/authorization.

To complete the recovery, I put the new etc/authorization.plist on a USB stick, plugged it into the Macbook (still in single user mode) and mounted the drive as follows:

mount -uw /
launchctl load /System/Library/LaunchDaemons/com.apple.kextd.plist
# Wait about 20 seconds

mkdir /Volumes/usb
mount -t msdos -v -o ro /dev/disk1s1 /Volumes/usb

Then I copied the file to its destination, unmounted the USB stick, synced and rebooted successfully:

cp /Volumes/usb/authorization.plist /etc/authorization
umount /Volumes/usb
sync
reboot
  • weird issue: when I hit D in the startup, it brought up the Internet Recovery loading screen. I looked it up and that screen is only supposed to come up with Command+Option+R. – Jaketr00 Mar 16 '16 at 21:04
1

A verbose boot (Command-v) will tell you where the install is hanging. It'll spew a lot of text, then hang (presumably) on some line. That's where you can start to see what's going wrong. Post that line here and there may be clues.

You can try a single user boot (command-s) as well, which skips the UI and drops you to a command line, but that can be harder in terms of diagnostics.

0

http://www.apple.com/support/macbookpro-videoissues/

Apple has issued a Repair Extension Program for Video Issues. I was experiencing the same problem and had tired several solutions that worked for a short period of time, but ultimately I was unable to get my MBP up and running last night and brought it into an Apple store. They determined that my issues was in fact a video issue and qualified for free service.

If you purchased a MBP between February 2011 and December 2013 and suspect that your MBP is experiencing the same issue and check out the page URL above to see if your MBP qualifies for service.

Here's an excerpt from the page

=========

Apple has determined that a small percentage of MacBook Pro systems may exhibit distorted video, no video, or unexpected system restarts. These MacBook Pro systems were sold between February 2011 and December 2013.

Apple or an Apple Authorized Service Provider will repair affected MacBook Pro systems, free of charge. See below for details on affected models and service options.

Symptoms

An affected MacBook Pro may display one or more of the following symptoms:

Distorted or scrambled video on the computer screen No video on the computer screen (or external display) even though the computer is on Computer restarts unexpectedly

Products affected 15-inch and 17-inch MacBook Pro models manufactured in 2011 15-inch MacBook Pro with Retina models manufactured from Mid 2012 to Early 2013

  • I've now got the same issue (have black screen, stuck progress bar, now even CMD+R shows a grey screen on the external monitor). However, mine is a late 2013 MBP. Going to try calling to see if the range is extended, as it sounds all so similar. – GilesDMiddleton May 10 '16 at 11:31
0

I had success with this method:

Boot into single user mode by holding down commands as soon as you hear a boot chime. This works on Bluetooth keyboards too.

It should boot to a command line.

Once in single user mode do the following commands at the command line.

/sbin/fsck -fy /sbin/mount -uw / rm -f /Library/Preferences/com.apple.loginwindow.plist rm -f /var/db/.AppleUpgrade reboot

-1

I had a very similar problem. I went through all the reboot procedures, but still nothing but gray screen. I finally took it to a local mac repair shop, and my FileVault is defective. They turned it off and all is well. They recommend that I leave it off otherwise the same thing can happen, and some cases it wipes out all your data...

You must log in to answer this question.

protected by Community Oct 22 '17 at 13:12

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .