I am using Office365 with Mail, Contacts, Calendar, Reminder, Notes (i.e. no Outlook). Why do I get e-mail addresses added to Contacts? These addresses are of people I do have in Contacts already. Why do they keep coming back as e-mail adders only ([email protected]) without name or anything else? I have deleted all entries from "Previous Recipients" and deleted the unsolicited entries. It did not help. Is this an Office365 "feature"?
(Mac 10.9.2)

After checking with another account I have on same computer, this seems to be an Office365 "feature." How do I turn it off? I do not see an option in Outlook (web or desktop versions) to stop arbitrary collection and addition of e-mail addresses.

  • I am confused with your question, maybe others 2 and that is why you not not getting a answer. So you use mail.app and you DO NOT use Outlook. Why would you look for a Outlook feature/options if you do not use it? Final question for clarification: the address collection happens in Contacts.app? or where ?
    – Ruskes
    Commented May 7, 2014 at 17:46
  • When adding an Exchange account, mail goes to Mail.app, contacts go Contacts.app, notes go to Reminders.app, etc. Yes, address collection happens in Contacts.app. @Buscar, Please see exact location in comment to your answer.
    – Irony
    Commented May 10, 2014 at 16:16

1 Answer 1


The Mavericks Contacts.app has settings were you can set/decide which one and where from the contacts come from.

Open Contacts and look on left site to see what you have set up there.

Also look at your settings in Contacts-Accounts to see what you have set up there.

  • On the lefthand side there are few entries: "All Contacts," "Exchange," "Local Computer," "Exchange Groups," and "Last Import." Unsolicited addresses appear under "All Contacts." Under "Exchange" there are no unsolicited entries. I have combed settings of: Office365, Mail.app, Contacts.app, and Internet Accounts in System Preferences. I did not find any checkbox, radio button, or drop down that lets me choose what addresses are automatically saved.
    – Irony
    Commented May 10, 2014 at 16:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .