0

I have a Windows 7 x64 Update 1 guest VM on a host with OS X Mavericks (10.9.2) and VMware Fusion 6.0.3:

  • The Windows 7 guest has a sparse HDD of 30 gigabyte, with about 5 gigabyte free, and the latest VMware Tools running.
  • OS X indicates the full size of the VM directory is (32,2 GB on disk) for 655 items (most of the items are in the various caches, most of the size is in the VMDK files)

enter image description here

VMware claims that VMware Fusion can reclaim space, but in my situation VMware Fusion never shows it can consolidate.

I tried this again with a Windows 8.1 110 gigabyte HDD that has about 10 gigabyte free: same result.

This is what I tried to force VMware Fusion to recognize there is something to consolidate:

  1. shutdown the VM
  2. defrag the VM, then shutdown the VM
  3. defrag the VM, then shutdown the VM and restart VMware Fusion
  4. defrag the VM, run sdelete -c C: inside the VM, then shutdown the VM, then restart VMware Fusion

Still no luck: the reclaimable size stays zero (see image below).

What should I do to force reclaim of the disk?

enter image description here

  • Same for VMware Fusion 6.0.4 and same for Windows 8.0 and 8.1 clients. – Jeroen Wiert Pluimers Aug 7 '14 at 16:16
1

For Windows 8.x, this works:

  1. Defrag the C: drive with these commands to defrag the files, then the free space:

    defrag /v /h /u C:
    defrag /x /v /h /u C:

  2. Reclaim the disk space in VMware Fusion 6.0.4:

    • Shut down the virtual machine.
    • Go to Virtual Machine > Settings > General.
    • Select Clean Up Virtual Machine.

Somehow this does not work for my Windows 7 VM. I even tried MyDefrag free space optimization without success.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .