7

I want to update my OS X Mavericks USB key and would like to be able to see what my mac is doing after I enter the following command.

sudo /Applications/Install\ OS\ X\ Mavericks.app/Contents/Resources/createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install\ OS\ X\ Mavericks.app --nointeraction

When I run the command as it is currently, only some information is output to the terminal, and while the install is copying over, the terminal does not display any info about what is going on.

I know that --v usually displays each step in the terminal window as it takes place, but I tried adding that to the end of the above command and it did not work.

I tried both with -verbose I get a not a valid mount point error.

When I tried --verbose I got the following error

createinstallmedia: unrecognized option `--verbose'
Usage: createinstallmedia --volume <path to volume to convert> --applicationpath <path to Install OS X Mavericks.app> [--force]

Arguments  
--volume, A path to a volume that can be unmounted and erased to create the install media.
--applicationpath, A path to copy of the OS installer application to create the bootable media from.
--nointeraction, Erase the disk pointed to by volume without prompting for confirmation.

Example: `createinstallmedia --volume /Volumes/Untitled --applicationpath /Applications/Install OS X Mavericks.app
0
5

You can use the verbose option only if the command itself provided it, which means that the programmer of the command you want to use has to check for the verbose option and set a flag its code so that the program outputs additional information. So if a command does not have a verbose option you cannot do anything about it. However it might output some information in system log files.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .