I just got a new macbook and is now installing apps to it. After setting up Dropbox and everything else, I decided that I wanted to change the account name (which was previously "mac") to my name. Everything worked fine, until I tried to open Dropbox, it asked for permission to the wrong user folder (of the old account name) like this:

enter image description here

I tried unlink my computer from Dropbox account and reinstalling Dropbox, the software keeps looking for that folder's permission. What should I do to fix this? Please suggest and thanks.


After I type my login details, this is what I got:

enter image description here

The thing is the folder /Users/mac doesn't exist. I click on the link of the dialog and got this log:

bn.BUILD_KEY: Dropbox bn.VERSION: 2.6.31 bn.DROPBOXEXT_VERSION: failed bn.is_frozen: True pid: 489 ppid: 233 uid: 501 user_info: pwd.struct_passwd(pw_name='ichigo', pw_passwd='********', pw_uid=501, pw_gid=20, pw_gecos='Huong Do', pw_dir='/Users/ichigo', pw_shell='/bin/bash') effective_user_info: pwd.struct_passwd(pw_name='ichigo', pw_passwd='********', pw_uid=501, pw_gid=20, pw_gecos='Huong Do', pw_dir='/Users/ichigo', pw_shell='/bin/bash') euid: 501 gid: 20 egid: 20 group_info: grp.struct_group(gr_name='staff', gr_passwd='', gr_gid=20, gr_mem=['root']) effective_group_info: grp.struct_group(gr_name='staff', gr_passwd='', gr_gid=20, gr_mem=['root']) DYLD_LIBRARY_PATH: None cwd: u'/Applications/Dropbox.app/Contents/Resources' real_path=u'/Applications/Dropbox.app/Contents/Resources' mode=040755 uid=501 gid=20 parent mode=040755 uid=501 gid=20 HOME: u'/Users/ichigo' appdata: u'/Users/mac/.dropbox' real_path=u'/Users/mac/.dropbox' not found parent not found dropbox_path: u'/Users/mac/Dropbox' real_path=u'/Users/mac/Dropbox' not found parent not found sys_executable: '/Applications/Dropbox.app/Contents/MacOS/python' real_path='/Applications/Dropbox.app/Contents/MacOS/python' mode=0100755 uid=501 gid=20 parent mode=040755 uid=501 gid=20 trace.file: '/Applications/Dropbox.app/Contents/Resources/lib/python2.7/site-packages.zip/dropbox/boot_error.pyc' real_path='/Applications/Dropbox.app/Contents/Resources/lib/python2.7/site-packages.zip/dropbox/boot_error.pyc' not found parent not found tempdir: u'/var/folders/l1/f5mv9brd0s5fwx12z2lrp4s40000gn/T' real_path=u'/private/var/folders/l1/f5mv9brd0s5fwx12z2lrp4s40000gn/T' mode=040700 uid=501 gid=20 parent mode=040755 uid=501 gid=20 Traceback (most recent call last): File "dropbox/client/main.pyc", line 1818, in main_startup
File "dropbox/client/main.pyc", line 1048, in run File "dropbox/client/main.pyc", line 492, in startup_low File "dropbox/client/main.pyc", line 314, in safe_makedirs File "os.pyc", line 150, in makedirs File "os.pyc", line 157, in makedirs OSError: [Errno 13] Permission denied: '/Users/mac'

Please note the lines I've emphasized with bold text: the wrong path to Dropbox was given. It should be /Users/ichigo instead

  • Login with your current Macbook credentials?
    – Rob
    Commented Apr 24, 2014 at 9:02
  • @Rob I've edited my question, please check it out.
    – huong
    Commented Apr 24, 2014 at 9:09
  • 1
    I ran into this exact same issue with one of my users two days ago. Unlinking Dropbox, completely removing Dropbox (from /Library & ~/Library preferences, caches, etc) and reinstalling Dropbox had no effect. So far Dropbox support hasn't responded to our help ticket. If they do I'll pass along the info, otherwise I'll be watching this question and would like to add a bounty to it once it's eligible.
    – Mr Rabbit
    Commented Apr 24, 2014 at 13:07
  • 1
    This was helpful for getting around the Dropbox issue. However, I found that so many applications had hard-coded the username that the best way forward was to create a new user with the desired username and start over.
    – jwhitlock
    Commented Jul 10, 2015 at 14:25

2 Answers 2


Funny timing, just received this back from Dropbox support and it seems to have resolved my user's problem. Her issue similarly popped up when we migrated her to a new Mac and then changed her user account name.

Thanks for writing in. If you're having trouble running Dropbox on your Mac then please try these steps and then restart Dropbox.

1. Stop Dropbox (If needed):

  • Click the Dropbox icon in the menu bar at the top of your screen
  • Click on the gear icon in the Notifications panel and select 'Quit Dropbox'

2. Download the newest version: www.dropbox.com/install

3. Open your Terminal app (Located at /Applications/Utilities/Terminal)

4. Copy and paste the following lines into the Terminal, ONE AT A TIME, and press ENTER after each one. PLEASE make sure you copy and paste these commands (don't type them by hand), as getting them wrong could cause some harm. You'll be prompted for your computer's admin password (not your Dropbox password) after entering the first command. Keep in mind that the password field in the terminal will remain blank as you type your password. After you type it, just press ENTER.

sudo chown "$USER" "$HOME"

sudo chown -R "$USER" ~/Dropbox

sudo chmod -R u+rw ~/Dropbox

sudo mv ~/.dropbox ~/.Trash/dropbox.old

sudo mv ~/.dropbox-master ~/.Trash/dropbox-master.old

sudo chmod -N ~

sudo mv /Library/DropboxHelperTools ~/DropboxHelperTools.old

5. Open the .dmg file from step # 2 and double click the Dropbox icon to install Dropbox.

6. Restart Dropbox from the Applications folder.

Hopefully that does the trick for you as well!

  • 1
    Really nice timing haha! This totally solves the problem, thanks so much for your time.
    – huong
    Commented Apr 24, 2014 at 15:49
  • 8
    In my case, all I needed was mv ~/.dropbox ~/.Trash and sudo mv /Library/DropboxHelperTools ~/.Trash.
    – Andrew
    Commented Nov 10, 2014 at 16:39
  • 1
    If you wanted to remove them, then why not simply rm -rf ~/.dropbox? Commented Nov 1, 2016 at 9:00
  • Steps still work in 2021! Thank you - tried all the Dropbox support provided steps without luck. The ones mentioned above did it. Commented Jan 7, 2021 at 19:49

Uninstall and re-install:

rm -rf ~/.dropbox/ && rm -rf /Library/DropboxHelperTools

Then run the installer again.

  • Better than the Dropbox-provided answer. Except that it should use sudo as follows: sudo rm -rf ~/.dropbox/ && sudo rm -rf /Library/DropboxHelperTools
    – rinogo
    Commented Jul 25, 2018 at 18:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .