1

When I tried to set my Terminal color by importing a color scheme stored in ~/Dropbox/.personal/myColor.Terminal, it didn't display the hidden directories, including ~/Dropbox/.personal (and other files and directories I store to my Dropbox root, such as .vimrc or .gvimrc).

Why does this not display it? I always show those hidden directories by setting the AppleShowAllFiles property in com.apple.finder to 1.

It's just the Terminal color setting import pane that I recognize to NOT be displayed - in other words, I've seen those hidden files everywhere on my daily use.

I can just move the color scheme file temporarily to import it on my Terminal - just want to know why such incongruity occurs.

I use the latest version of OS X Mavericks. Any feedbacks would be appreciated.

Update

I got that it's not only Terminal, but it can be applied to other applications as well, on which when you do Open Files or Import or similar operations, most applications don't display those hidden files. As far as I know, only MacVim has a checkbox option to open those hidden files.

  • Can you see the files in Terminal before you apply the colour scheme? – Mark Apr 22 '14 at 21:37
  • What do you mean in "see files in Terminal"? If you mean com.apple.Terminal.plist, then I can see the file's contents by issuing plutil -convert xml1 -o - com.apple.Terminal.plist. – Blaszard Apr 22 '14 at 22:14
  • Does ls show the files before you import the colour scheme – Mark Apr 22 '14 at 22:20
  • Yes, ls works properly. And I just noticed that it's not the issue on Terminal - check out my comment to the accepted answer. – Blaszard Apr 22 '14 at 22:30
  • You should add more information into the question if relevant - Comments should be treated as if they might be deleted in the future – Mark Apr 22 '14 at 22:32
2

If I understand you correctly, this likely has to do with how terminals work. In bash they are hidden by most aliases of ls.

Try ls -a or \ls -a if that isn't working. This is to show all files and escape an alias you might have.

Put simply, the terminal doesn't care about finder preferences because it isn't finder.

If not, then perhaps terminal simply doesn't respect the finder settings.

  • ls -a (or more simply, just ls) properly lists all files including those hidden ones. But I just noticed that it's not only Terminal - most applications don't display those hidden files on the Open Files or Import or similar dialog. I didn't recognize it... MacVim has an checkbox option to show them, though. – Blaszard Apr 22 '14 at 22:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .