1

I have an iPhone 4, and one of their recent updates added an 'always online' feature, where the user can receive messages even if Skype isn't open on their device.

Lately I've been using Skype on my desktop PC, and any message sent to me also appears on my iPhone, and it gets a bit annoying after a while. Skype for iPhone has no settings, and I've turned off all notifications for Skype in the iOS notification centre, but however I still get notifications of the messages that I receive on Skype.

I've looked briefly for a solution to this, but I can't find anything specific to my usage case. Two questions:

  • Can Skype notifications for new messages be switched off on my iPhone- Switching all notifications off for Skype does not do anything.

  • Is it possible to stop it from showing me as Online all the time? It's inconvenient because I recieve business messages when I'm trying to sleep, and I require to be contactable 24/7 so I can be contacted by my customers if they have a fault with their gameserver (I offer gameserver hosting)- but being able to IM me 24/7 isn't what I want.

2

You may want to set your status to Offline. Or remove Skype app from the running task list (double-tap on Home, switch into Skype area and swipe to the top to get rid of it).

If that won't work and it changes back to Online, this potentially could happen when you're logged into your account multiple times from different devices, so the statuses could be not in sync.

For workaround there are some cloud-based chat commands which allows you to see where you're logged in and you can logout from the remote sessions.

  1. Create an empty conversation.
  2. Type command in the message textbox:

    /showplaces
    

    Lists other endpoints that can receive push notifications for calls and IMs for this Skype account.

  3. If you want to logout from remote online endpoints, then execute:

    /remotelogout
    

    Sign out all other instances except the current one. This will also stop push notifications on all other instances.


Other workaround could include changing your Skype password to make remote Skype clients sign out.

1

I do not think the new update shows you Online all the time, it just forwards all messages/notifications to your mobile devices so you receive copies whether or not you are Online. I agree this is annoying, there should be an in-app setting for disabling this. I don't know why there isn't one. It is a feature, not a requirement. You can always just sign out of the mobile app and use signing in/signing out to enable/disable notifications. An inconvenient workaround but it should work.

  • True, but a really inconvenient workaround. A friend who has had the same problem simply uninstalled it from their device; unfortunately for me this isn't really a feasible option. – zyboxenterprises Apr 3 '14 at 16:51
1

Try the /remotelogout command

source: http://community.skype.com/t5/Windows-desktop-client/Extreme-online-status-bug/m-p/2989680#M241734

0

Put your profile to invisible or offline when you don't want to be contacted and see how that works. Also power things completely down while sleeping.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .