0

I am using a Mac Terminal window to ssh to a CentOS server. I have installed vim-enhanced on the server, I have created an alias for vi=vim in my .bash_profile, as well as confirmed I am using /usr/bin/vim. I still can't get syntax colors when editing files.

Is there something I need to do with Mac Terminal settings? Any thoughts as to why it's not working as I expect?

1

Display ANSI colors needs to be enabled in the Terminal Settings.

0

Do you have the line syntax on somewhere in the file ~/.vimrc (on the host machine)? That should do it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .