11

I have a macbook pro running osx. It is identical to many others in my office. I am the only one who cannot connect to the office wifi network. I can connect to other networks just fine, but when I try to connect to this one specific network a dialog box replies with

The Wi-Fi network "office" could not be joined.

Try moving closer to your wireless router. Alternatively, run Wireless Diagnostics to troubleshoot.

Moving closer is not the solution. Diagnostics spits a lot of info, within which the wifi log is contained. During the join attempt the wifi log reported:

Tue Apr 22 14:37:28.028 <airportd[101]> composeEFIJoinParam: Invalid security type
Tue Apr 22 14:37:28.029 <airportd[101]> writeRecoveryNetworksToNVRAM: could not compose EFI join params
Tue Apr 22 14:37:28.029 <airportd[101]> _handleNewMessage: Received XPC message, event = USER_REQUEST_EVENT, pid = 175
Tue Apr 22 14:37:28.029 <airportd[101]> _handleNewMessage: Received XPC message, event = DEBUG_FLAGS_EVENT, pid = 1023

How can I solve this?

  • 1
    what security type does your office uses? WEP, WPA ... – Ruskes Apr 22 '14 at 9:03
12

Just to make sure, check with network admin that your MAC address is not blocked :)

The message posted indicates you might have a Firewall setting issue.

Open About this Mac + more info + system report and find the Firewall. Check the settings there making sure it is not blocking that network somehow.

Also make sure you do not have a 3D party Network software blocking that connection like Little Snitch or others.

Lets try to connect manually, using the Terminal:

Follow this guide to connect using copy paste.

In Terminal type following (to turn the airport on)

networksetup -setairportpower en0 on

Next type (to scan for networks and find the one you want)

/System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Resources/airport scan

Finally type (to connect)

networksetup -setairportnetwork en0 WIFI_SSID_I_WANT_TO_JOIN WIFI_PASSWORD

If the password is something weird like ASCI or HEX follow this guide.

3

I got it fixed by changing Wi-Fi channel in my router. I figured out my neighbor and I was on the same channel and his network signals were interfering with my Wi-Fi signals. So I changed my wireless channel from 1 to 11 by logging into the router and changing wireless settings.

2

I had the same problem. One possible solution is to delete the WiFi's settings from keychain. Search for 'Keychain Access'. Then select the 'System' option from left. Then delete your Wifi settings. It will then prompt you to enter the password again!

  • this worked when I encountered the problem after using Migration Assistant – rcrogers Jan 18 '17 at 0:12
1

The saved password may be incorrect or blank. Open Keychain, search for the wifi network name, and delete any saved passwords.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .