7

First of all, this problem is detailed in this discussion at Apple's forum.

I basically have the exactly same problem.

Status indicator is always yellow under "Bluetooth PAN" in Network Panel.

The status says: Bluetooth PAN has a self-assigned IP address and will not be able to connect to the Internet.

I tried on both iPad and Android devices, doesn't work. There is an icon on the upper left corner of iPad indicates connected to Bluetooth PAN. However, there is no internet access.

Any suggestions on this issue?

4

I ran into the same problem when reverse tethering my Samsung phone (Android 5.1.1) to access the Internet connection on my Macbook Air (El Capitan), and found a successful solution:

  1. Make sure your mobile device is paired via Bluetooth and follow Heiko Haller's steps for Internet Sharing settings.

  2. Under System Preferences > Network, select the active Internet connection (e.g., USB LAN) and note the IP Address, Subnet Mask and Router numbers.

  3. Select Bluetooth PAN in the same Network window, click the Advanced button in the lower right to open its configuration panel.

  4. Under the TCP/IP tab, select 'Manually' from the Configure IPv4 drop-down menu, and copy the information from Step 2 in the three relevant fields.

  5. Select 'Link-local only' next to Configure IPv6.

  6. Click OK to close the Bluetooth PAN panel, hit Apply in the Network window.

  7. On the mobile device, go to Settings > Bluetooth and click on the cog icon next to the paired Macbook and turn on 'Internet access'.

It's been a couple of hours and so far, the connection seems stable. Edit: An incoming regular call broke the connection, and unpairing and re-pairing the device appear to have restored it. Edit2: The IP Address and Router numbers may change each time you connect to the Internet, so be sure to update the Bluetooth PAN settings accordingly.

2

I followed the instructions above but the IP address 192.168.1.14 did not work for me.

I did however find a solution. While the PAN interface was connected, I ran ifconfig in terminal. There was a bridge interface with the IP address 192.168.2.1. So I set my PAN Interface to match and reconnected. Now it works!

  • 1
    This worked for me since I saw the same bridge interface via ifconfig. I had to delete and re-create the Bluetooth PAN and then set: [Configure IPv4: Manually] [IPv4 Address: 192.168.1.14] [Subnet Mask: 255.255.255.0] [Router: 192.168.2.1] [Configure IPv6: Link-local], and then under the DNS tab, set the server to 192.168.2.1. – vinod Nov 12 '17 at 4:40
  • Combining @Chisato and @Metthew Hand's answers, I set IP Address and router same 192.168.2.1, then subnet mask 255.255.255.0 for Bluetooth Pan configuration to make it work. – HendraWD Jun 9 at 11:19
1

I am not sure sharing an Internet connection over Bluetooth works on osx. If it does, it should work like this:

  1. Go to System Settings > Sharing
  2. Select "Internet Sharing" but do not click the checkbox yet
  3. on the right, select 'share your connection from:' 'Wifi'
  4. below, check 'Bluetooth PAN' if it exists
  5. Now check the Internet Sharing checkbox on the left.

If 'Bluetooth PAN' is not in the list, it is mybe not supported to share internet via bluetooth.

0

Connected only means the devices are connected via BT pan.

Your WiFi connection to Internet is not been shared.

That could be caused by DNS server settings problem.

When you configured the IP settings "manually" did you set the specific DNS sever IPs respective to your InternetServiceProvider (ISP)?

Also---Try going into network settings>change your location to a new one or may be create another?

  • Technically I am not able to understand you.I understood that my Internet service provide is not allowing multiple access points thats the answer?? How can i browse internet in any manner.Please suggest me the way to get internet on my mobile – iOSdev Oct 20 '14 at 5:28
0

This is what i did:

  • looked up IPv4 address of the Connected Mac Computer in the Router Software (i am connected through Ethernet via Fiber)
  • Entered the IP address of the Connected Mac under Bluetooth PAN - Using DHCP with manual address
    • in the same section i choose under IPv6 "only local-link"
    • click "Apply"

Bluetooth PAN went from yellow to green and i was able to Reverse Tether the Internet Connection from Mac/Ethernet via Bluetooth PAN to Android Phone (Samsung Note 3 on 4.4.2) and iPad 1.

I am hoping that this is a stable solution.

0

I assigned it an IP and it started to work, don't know why it can't do it automatically.

This is what I did:

  1. Go to System Preferences -> Network -> Bluetooth Pan (you might have to create this one)
  2. Press Advanced..
  3. Pick "Using DHCP with manual address" for "Configure IPv4"
  4. Enter an address under "IPv4 Address" (192.168.1.14 worked for me)
  5. Hit ok, hit apply.
  • 2
    Hi @Heinrisch. My device shows connected in android and in mac also shows connected.But I am not able to browse internet.Could you help me. – iOSdev Oct 17 '14 at 6:53
  • I have got to this point too:) – Mark Apr 12 '15 at 23:37

You must log in to answer this question.

protected by Community Jun 20 '17 at 17:41

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .