3

My wife has a MacBook Pro and two external hard drives; both of which currently contain a Time Machine backup of her MacBook Pro hard drive.

Now she wants to "turn off" Time Machine for one of her two hard drives, so that she can backup the MacBook Pro hard drive and the other external hard drive onto it.

In addition to the Time Machine backup, there are also additional files on the hard drive, so she cannot reformat it unless she first copies the files she wants to keep to somewhere else.

Is it possible to tell OS X "Do not recognise this external hard drive for use with Time Machine any more", so that it can be backed up using Time Machine? Currently, the external drive she wants to back up shows up in the "Exclude these items from backups"-list and cannot be removed, likely because it has been used as a Time Machine drive in the past.

How can she make it so that the one external hard drive (Drive A), can be backed up to the other external hard drive (Drive B), without reformatting it.

I appreciate any help with this.

1

Turn off Time Machine with the switch in System Preferences, then remove the Backups.backupdb from drive A.

Time Machine should recognise that the disk is no longer a Time Machine backup destination, but if it doesn't, delete .com.apple.timemachine.donotpresent from the root of the disk.

  • Thanks. I turned off Time Machine and removed the Backups.backupdb directory, however, Time Machine does not recognise that it is not longer a Time Machine backup destination. I can not find a file called .com.apple.timemachine.donotpresent in the root of the drive. – Leif Apr 21 '14 at 15:38
  • The hidden directories/files that remain in the root of the drive are: .DS_Store, .DocumentRevisions-V100, .Spotlight-V100, .TemporaryItems, .Trashes, .VolumeIcon.icns, .apdisk, .disk_label and .fseventsd — I'm not sure which of these (if any) are part of the old Time Machine backup. – Leif Apr 21 '14 at 15:44
  • 3
    Ah! Figured it out. Turns out that Apple has added a "right-click option" in the Time Machine preferences window, with an option to "Remove Backup Disk…" — After selecting this option, I was able to remove the disk from the exclusion filter, and now it seems to be backing up to the other external hard drive. – Leif Apr 21 '14 at 17:04
6

Go to Time Machine preferences, Ctrl-click on the drive you want to disable, you get a fold out menu with the option to disable the drive.

You must log in to answer this question.

protected by Community May 14 '15 at 3:06

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .