0

When I plug in a third party mouse into my iMac it does not get any power. I've tried the USB port on the keyboards and directly on the machine. I've tried two mice and one of them used to work (I used it for gaming). Any ideas where to start debugging?

It only seems to occur when using a mouse on that port. USB flash drives etc work just fine.

  • Is the mouse identified by your iMac ? – Ruskes Apr 20 '14 at 11:51
  • It is not identified. It also has a red light indication that it is on, which does not light up. – Benedikt Wutzi Apr 20 '14 at 16:18
  • I wish for an lsusb ;) – Benedikt Wutzi Apr 20 '14 at 16:21
  • what mouse is it, maybe there is a driver for it – Ruskes Apr 20 '14 at 16:28
  • It's a cheap no name mouse. The thing is that it used to work until a few days ago. – Benedikt Wutzi Apr 20 '14 at 16:47
1

I also had a similar problem. Try to identify whether the problem comes from the mouse or the iMac : try to plug the mouse on another computer and connect something else to your computer.

My problem came from the usb port of my computer so I had to take it back to the apple store ..

Sorry I couldn't give you a way to solve your problem immediately.

  • I usually plug it in a USB port on my keyboard. I use this port for my mighty mouse, but gameing with a mighty mouse just sucks. I used to change the mouse for at least 1 year on that port. The mighty mouse works just fine. I also tired all other ports on the iMac and different mice. – Benedikt Wutzi Apr 20 '14 at 16:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .