3

So I have OSXFUSE & fuse-ext installed (as in link: How can I mount an ext4 file system on OS X?), but after searching on these two device's websites, Stack Exchange, googling, etc. I cannot find the answer to my question:

My 10.6.8 mounts ext4 automatically but I can only read files - I wish to be able to write on there as well.

What I have been doing is unmounting the partition:

sudo umount /dev/disk0s4

and then remounting it with:

sudo fuse-ext2 /dev/disk0s4 /Volumes/disk0s4 -o rw+ -o allow_other

and it works. BUT, I tried to add the above line in /etc/fstab and Mac decides to ignore it and create a new mount point under Volumes - which I thought was something it shouldn't do...

Any ideas?

P.S. I know fuse-ext2 is supposed to only work with ext2 (maybe ext3) (maybe ext4) but I haven't looked into that...

  • maybe create a launchd entry for this ? – rwenz3l Apr 19 '14 at 12:58
  • yes, I had thought of something like that too, and I think its a good idea. I also wondered about a line in fstab saying "noauto" for /dev/disk0s4 and then a line later saying "fuse-ext2 /dev/disk0s4 /Volumes/disk0s4 -o rw+, -o allow_other 0 0" (I may be mixing my linux and mac notation...) – nate Apr 20 '14 at 2:29
2

I finally found something that worked, and I have verified it does as well. Please see the link: http://www.dbsysnet.com/how-to-mount-ext2ext3-linux-volumes-in-mac-os-x-snow-leopard-with-readwrite-access/

Basically there is a mount option that can be added "rw+" to the file:

/System/Library/Filesystems/fuse-ext2.fs/fuse-ext2.util

under the Macro() function.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .