0

My contact list op my iPhone 5s suddenly shows hundreds of contacts for people that I do not know with full contact info. I have synced with Facebook and have LinkedIn and Exchange installed, but these contacts are not part of my "friends". Has anyone experienced the same issue? What can I do?

  • Look if any of your accounts are hacked, by changing the passwords on them. – Ruskes Apr 19 '14 at 8:36
  • Do they show up in your iCloud Contacts? – 0942v8653 Apr 19 '14 at 11:58
0

There are many possibility:

1: Facebook sync with your contact info, as I know, Facebook will suggest people you may know to you.

2: Are you using a same Apple ID with your families or friends? Contacts will sync to your other device with same Apple ID.

3: Are you using other's SIM card? SIM card store contact inside the micro chip!!

4: Your Apple ID have been hacked.....change your password immediately and never tell others your ID and password.

0

You need to deselct contacts under the facebook app in settings, then select 'dont allow changes' under settings and restrictions.

0

Turns out, that Outlook had synchronized thousands of contacts from MS CRM. Deleting them from Outlook solved the problem.

-1

For me it seemed to be Outlook contacts.

enter image description here.

I checked the group settings in Contacts as you see in the picture and all the junk contacts went away.

  • Can you clarify on how checking the group settings caused the junk contacts to no longer be present. Are you saying that you unchecked an option visible in the screenshot? – Jake3231 Mar 22 '18 at 3:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .