This problem happened suddenly on my MacBook pro: when I insert a CD/DVD, it tries to read it for a few seconds (the motor of the DVD drive is working) and then it stops, and ejects the DVD.

I have read in many forums that this is a dead condition for DVD drive, and should be replaced. But some others also suggested the lens might require cleaning. Does anybody have experienced the second situation (i.e. can the problem be solved using DVD drive lens cleaner kits)?

  • Could you publish few lines of Console around that time stamp of the event
    – Ruskes
    Apr 19, 2014 at 8:09
  • They used to sell CDs with a little brush glued onto them, and a bottle of cleaning fluid to put on the brush. It fixed my CD drive multiple times back in the 1990's. Don't know if the cleaner is still sold. Sep 11, 2019 at 22:54

9 Answers 9


Try the following steps and I am sure it will be fixed.

  1. Clean the SuperDrive’s slot with compressed gas/vacuum cleaner.

  2. Reset the NVRAM/PRAM and SMC

    • Reset NVRAM and PRAM:
      Shut down the computer. Holding down the option + command + P + R and then hold the Power button simultaneously, 3 times and wait for 3 loud chimes.
  3. Delete the Finder’s preference files

    Some people have reported successfully fixing Optical CD/DVD Drive on Mac or SuperDrive issues by deleting the Finder’s preference files (don’t worry, the Finder will automatically make new ones). You’ll want to delete two files: “com.apple.finder.plist” and “com.apple.sidebarlists.plist”. Both of these files are located in Users > [Your User] > Library > Preferences.

  4. Run Disk Utility and Repair Disk Permissions

  5. Delete the following configuration file to create a fresh copy

    ~/Library/Caches (your local Library directory). 
    /System/Library/Caches/com.apple.kernelcaches (a directory).
    /System/Library/Caches/com.apple.romextensions (a directory).
    CD Info.cidb

Credits - http://coreyjmahler.com/2013/06/15/how-to-fix-a-macbook-pro-superdrive-which-continually-ejects-discs/

  • 3
    Is this plagiarized from coreyjmahler.com/2013/06/15/… - if so, please edit this appropriately - the community frowns upon presenting other's work as your own. It's also agains the terms of the site.
    – bmike
    Aug 29, 2015 at 16:44

enter image description here

This is how I fixed it. :) I tried resting it normally after it eventually registered, but it wouldn't stick. So obviously not a long term solution..

  • So, what you are saying is that it's a physical problem with the drive meaning it should be serviced?
    – Allan
    May 14, 2017 at 19:06
  • This worked for me too. I'm using an external CD player (connected via USB). Holding the CD player at a 90-degree angle kept the CD from immediately ejecting. I was able to rest the CD player normally on the table after the CD was mounted by the computer. This problem only occurs for me with certain, specific CDs.
    – Jasha
    Jun 26, 2018 at 22:08

This has happened to me a couple of times over the years, all I do is hold down the command key and the disc drive accepts it. I have an iMac (24-inch, Early 2009) running Yosemite 10.10.5

  • Holding down the command button while inserting the disk worked! No lens or drive slot cleaning and no reseting the NVRAM/PRAM and SMC required. Holding my 2010 MacBook at a right angle didn't work. Only needed to hold down the command key and insert the disk as usual. Thanks,
    – C. H.
    Nov 26, 2018 at 3:21

Worth noting, this can happen if you insert the disk upside down


I decided that mine might be dirty so I took a credit card sized card, wrapped in a spectacles cleaning cloth, inserted it into the left hand side of the slot and wriggled it about for a bit. Success! No need for SMC or PRAM etc work this time and it really figures that dirt might be the problem.


Lets analyze:

The Loading/Unloading works !

The spin motor works !

So electromechanical it is OK.

Since you would have to take it out anyway here are the instructions how,to open it

and how to clean the lens.

  • Thanks, the page contains the instructions only to remove the drive, not to clean the lens
    – Ali
    Apr 19, 2014 at 8:40
  • That was the step 1, see my update for step 2
    – Ruskes
    Apr 19, 2014 at 8:53
  • Please do come back and tell if it worked for you.
    – Ruskes
    Apr 19, 2014 at 9:16

I had the same problem after updating to Mavericks. Resetting the NVRAM solved it.


For me it seemed to be a combination of logging in (iMac 21.5" mid 2011) and holding the command key as suggested before. not sure if it was the not logging in or the not holding the command key that did it though


Cleaning the lens really worked plus holding down the command button

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .