When I start OS X (Mavericks) and run ps aux | grep postgres from Terminal, I have a process that was automatically started:

postgres          132   0.0  0.1  2526456   7936   ??  Ss   10:04PM   0:00.07 /Library/PostgreSQL/9.2/bin/postmaster -D/Library/PostgreSQL/9.2/data

This is a problem because I recently installed HomeBrew's version of Postgres and want that to be the postgres that is always running. However, I can't figure out how to disable the old one (above) and it is driving me crazy! I've looked for launch agents in:


and can't seem to find one matching the above... any ideas?

  • Nevermind, found it in /Library/LaunchDaemons on a careful second look... those really seem to be all the possible places that startup processes load from.
    – B Robster
    Commented Apr 19, 2014 at 4:44

1 Answer 1


The related launchd job ticket was found in /Library/LaunchDaemons.

Answering to mark question as successfully resolved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .