1

I have a MacBookPro OS X 10.7.5 from 2011. When trying to boot it has a slow startup or login, with numerious spinning wheels. Sometimes after a long time I can sign into the computer and sometimes it just fails to startup or login.

It became more serious recently as I think I might have let my battery run out. Once it did boot and I also tried to download the operating system to reinstall it but it allways stops around 1.4 GB out of 1.7 then the wheel spinning started again.

Now it wont boot at all, so I tried to boot in in safe mode. After the shift key it took about a half hour until the time bar at the bottom filled up, and when it did the screen went black. When it hit the start button it went back to the safe startup screen with the gray apple, spinning wheel and bar filling up at the bottom.

  • Try booting in verbose mode, where it displays what is happening in real time. You can do this by holding down command+V while powering it on. Post back or edit your question to include the lines that it appears to be hanging on. – Mr Rabbit Apr 17 '14 at 16:33
  • 1
    I'm getting a lot of stuff such as:missing thread record, checking catalog count, Invalid directory, Invalid node structure, disk)s2: I/O error, and it is still going – helman Apr 17 '14 at 16:46
  • 1
    I'm getting a lot of stuff such as:missing thread record, checking catalog count, Invalid directory, Invalid node structure, disk)s2: I/O error, and it is still going. Now it has a long list of Missing directory record – helman Apr 17 '14 at 17:01
5

The "invalid node structure" and "disk I/O" errors you see in verbose mode are both indicative of a failing hard drive.

The invalid node structure points to a problem with the data cataloging mechanism of the operating system, basically that system that keeps track of where all the data is stored. One off reports of this aren't so bad but coupled with the issues you're seeing and the other error message I imagine it's a result of a failing drive.

The Disk I/O error pops up when the hard drive is inaccessible, either for a split second or several minutes. This can usually be attributed to any of the following:

  • SATA port on the logic board going bad (not very likely)
  • Hard drive cable going bad (somewhat likely)
  • The hard drive itself failing or starting to fail (much more likely)

Because the disk is temporarily unavailable you often see system corruption (such as the invalid node structure error above) occur as a result.

So, what to do from here...

  • Definitely don't try to install a new operating system. The process of doing so is one of the most taxing procedures a hard drive is likely to go through in normal use, on a failing drive it can stress it to the point of complete failure.
  • Backup your data if you haven't already. If your Mac does manage to boot again I would strongly encourage you to copy whatever important data you might have (pictures, documents, etc) to a thumb drive or external hard drive. If you're unable to do this then I would recommend checking with local AASPs (see two paragraphs down) to see about data recovery options.
  • Repair. Depending on your comfort level working with computers you might attempt to repair your Mac yourself. As I mentioned, the hard drive is the most likely culprit, iFixit has a guide that walks you through the process - MacBook Pro hard drive replacement. Almost any 2.5" SATA hard drive will work as a replacement.
  • If you prefer to have someone else repair it you can find Apple Authorized Service Providers (AASPs) and Apple retail stores using Apple's locate tool. If your Mac is under warranty (you can check with this tool) then the repair would likely be covered by both Apple and/or an AASP so long as it wasn't a result of accidental damage. If it's not covered then I would get a quote from each shop.

Hopefully that helps or at the very least gets you started.

  • 1
    Mr Rabbit: You gave me an excellent answer. I really suspected it was the hard disk, as I did drop my laptop and cracked the screen, but it still somewhat worked until now. Thanks a million.The H Man – helman Apr 17 '14 at 18:41
0

The above answer is wrong. I have repaired many disks with this error and they are all still running (and smart reporting as fine) years later.

Try this, in order to fix it (I posted this to the apple forums a couple years ago and I am still getting emails from people thanking me, so we know it works).

Invalid Node Structure is not a hardware failure, it never was (you may still have a hardware failure, but the Invalid Node error is not indicative of this problem.

Still, Disk utility will certainly fail to fix it, and DiskWarrior will probably fail too.

But don't despair. Try this, and don't give up till you've tried it at least three times.

First, get the name of the partition of the failing volume. You can get it most easily by finding your disk in Disk Utility, selecting your partition (not the drive) and type cmd-i. Look for "Disk Identifier" right at the top.

Then, open up Terminal, and type this:

sudo /sbin/fsck_hfs -yprd /dev/disk5s2  

substituting your disk identifier for the one already here. Keep the /dev/ part. Enter your password, and wait. It may take a while. I have had this fail several times before finally working so its important to keep trying. It's faster than a reformat!!!

If the afflicted disk is your startup disk, you will need to do this in recovery mode: restart the computer, hold down option, and wait for the disk options to appear. Select that, then proceed to Disk Utility and then Terminal as described above.

Good luck, and always keep a backup!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .