7

I've bought a USB ethernet adapter (A1277) and tried to make it work on my MacBook Air MD231 (mid 2012) and may OS is OS X Mavericks, but It's not working. I tried adding USB ethernet connection in network preferences, tried resetting PRAM and SMC, and also tried installing drivers given here, but none of them worked. Rebooting didn't help, and I don't have Android file transfer installed (I've uninstalled it couple of days ago), which I saw people saying that uninstalling that helps fix the problem.

What should I do?
thanks

enter image description here

7

For reasons best known to itself, Apple chose not to include updated drivers for the A1277 adapter when it released Mavericks. In the screenshot you provided, the 'Product ID: 0x1402' in reference to your adapter reveals it was manufactured by ASIX Electronics, and further indicates that ASIX designates it internally as a model AX88772C. (This information comes from the massive OUI database of model and vendor codes maintained by the IEEE.)

Happily enough, even though Apple no longer continues to support the product, ASIX does. Their current driver version (2.2.0) for the A1277 / AX88772C includes support not only for Mavericks, but for Yosemite as well.

You will find the link to download "Apple Mac OS X 10.5 to 10.10 Drivers Installer" as the first entry in the list of driver downloads on this page of the ASIX site: http://www.asix.com.tw/download.php?sub=driverdetail&PItemID=136

  • Thank you! I tried like 10 different drivers before getting to this one. I bought a no name USB-ethernet hub (with 3 usb ports) on Ebay, but could not get it to work on Yosemite. This did the trick! – Gene Parcellano Nov 4 '14 at 18:05
  • @Gene Parcellano: You're quite welcome. – Doc G. Nov 5 '14 at 13:38
  • this worked for me 2012 air, yosemite, with A1277 usb. after installing and rebooting make sure you add the usb ethernet to the network settings. Follow the instructions in the pdf that came with the download. – mihai Dec 6 '14 at 21:14
  • I have a UGreen USB 3.0 to 1.0/100/1000MBps adaptor. System report revealed model AX88179. Appropriate drivers were available and a download, install, and reboot fixed the problem. Thanks! – Max MacLeod Nov 23 '16 at 21:51
  • Did not work for me on windows 10 virtual box .... still says device cannot start (error code 10). hardware id is indeed 1402... tried AX88772, *A, *B, and *C.... – user391339 Nov 20 '17 at 0:59
0

Apple recommends following

Connect the USB Ethernet adapter before you power on your computer.

If you have reached a step in Setup Assistant where the Ethernet options are grayed out or not displayed, follow these steps:

Press Command-Q.
Click Shut Down.
Connect the USB Ethernet adapter to the computer.
Start up the computer.
Complete Setup Assistant.

But since you have a newer model with Thunerbolt the USB-Ethernet wont work. I would suggest the Thuderbolt-Ethernet adapter.

0

I had a similar problem, I would see the Device in the Network Settings but it would be unable to put a link up (switch lets off) or get an IP. I tried using DHCP with manual address which fixed the issue. The interface went up and it picked up the gateway and DNS correctly over DHCP. So I suspect my DHCP server is behaving funny and the Apple USB Adapter is doing the same since I had to spend two hours tried to figure what's wrong, I almost did a restore of my laptop which would have been a pain with getting everything back up.

0

This worked for me. The A1277 corresponds to the ASIX AX88772. 1. Download the driver from there website http://www.asix.com.tw/download.php?sub=driverdetail&PItemID=105

IMPORTANT! 2. Follow the instructions in the pdf file. To install the driver.

If you follow the instructions in the pdf file that is attached to driver this should work in 10.9 and 10.10.

  • Could you provide some explanation not just links – Mark Oct 28 '14 at 16:06
  • Well the solution is in download the driver open the zip file and read the pdf file. Its an step by step guide in the zip file with the driver. I dont want to copy those instructions to this website. Everything is on that link. And it solves the problem. – sand Oct 28 '14 at 16:12

You must log in to answer this question.

protected by Community Nov 4 '14 at 8:11

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .