some folders on my mac asks your my password to rename, add, delete files in a folder. I checked the folder privileges in Get Info to compare with normal folders, it was the same but the result is totally different. Can anyone tell me how to disable or fix permission issues for finder folders? Thanks!

  • 1
    Are the folders in your (or someone else's) home folder?
    – grg
    Apr 16, 2014 at 13:53

2 Answers 2


Generally speaking repairing permissions is a quick and easy task. head on over to /Applications/Utilities and look for Disk Utility. Launch it, select your HD and then click on repair permissions and let it do it's thing. That could take a couple of minutes or 15-20 depending on how messed up things are.

When I do this I usually quit out of ALL other apps and let disk utility do it's thing in peace. Then I run it again, and again until I get no more errors.

All of that assumes that it is a simple permissions error. It could be you are trying to modify a folder in a location that Apple does not want you changing things, the /Applications and /Applications/Utilities folder spring to mind.

If, however, these issues are on your desktop or in the folders Apple sets aside for your files (documents, music, pictures, etc.) then yes there is a problem and it MIGHT be more than permissions. Could be actual disk errors.

In Disk Utility you can "Verify Disk" but you can't "Repair Disk." That requires booting from install media, the recovery partition or the disk repair utility of your choice (my choice is Diskwarrior, YMMV).

If repairing permissions doesn't fix the issue AND you are working with folders Apple deigns to allow you to work with, use Disk Utility (or 3rd party tools) to repair the disk/file structure.

  • Hello! Sorry for my late reply, the folder with permission issues are in Apple's default folder, "Pictures", inside it there is a sub-folder called Unsorted Pictures, Scans and other sub-folders. Those sub-folders contains permission issues.
    – Jimmy Wong
    Apr 18, 2014 at 14:12
  • Yah I would run repair permissions a couple of times and then, if necessary repair disk. You should be able to add and delete folders at will in there. Apr 18, 2014 at 15:00
  • Hello, I have Verify and Repair Disk Permissions from internet recovery. It didn't help at all, even I download third party software like Stallar Volume Repair to fix permissions, it didn't help. Is my problem unique or there is another way to fix that?
    – Jimmy Wong
    Apr 18, 2014 at 15:15
  • OK then create another User, log in under that username and see if the issues repeat. If they don't there is something specific to that user profile that is damaged (not sure what). If the same problem exists you may want to attempt to either apply the latest COMBO updater or just re-installing the O/S right over top of what you have (after a backup, of course...) Apr 18, 2014 at 16:22
  • The problem still exists on a new administrator account. I applied the latest COMBO update 10.9.2 and no difference. I am thinking about to rebuild the folders with problems. I think that might help.
    – Jimmy Wong
    Apr 19, 2014 at 1:34

I fixed it by copying the folder to external drives and copying back into the Pictures folder.

  • Interesting fix. That probably indicates that the folder(s) had gotten some wrong permissions set. In case it happens again you might want to open up terminal and issue this command: ls -fal you'll get a long listing of the current directory's contents (likely your home folder) save that output and if it happens again post the before and after and we may be able to help better. Apr 21, 2014 at 17:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .