1

I've been using my MBA in clamshell mode connected to a Samsung B2330 LCD monitor for about 2 days, using an Apple Mini Thunderbolt to DVI adapter. After taking it out of clamshell mode yesterday to use as a laptop, there was a heavy flicker on the screen. It seemed to affect mostly the startup screen and background image. Panicking, I started googling for solutions, people reportedly fixed it by resetting the SMC and PRAM. I tried that a few times and I don't think that it worked. But after a few minutes the flickering started to gradually go away, until it eventually became normal again. I'd say it took about 10 minutes to become normal again.

My procedure for taking the MBA out of clamshell mode is:

  • Put MBA to sleep from the Apple menu.
  • Switch off external screen.
  • Unplug peripherals from MBA.
  • Open up MBA and use as laptop.

My question is, does anyone know why this is happening, and what the fix is?

4
  • What is the reason for your procedure?
    – Ruskes
    Apr 16, 2014 at 9:00
  • I think it was from this support.apple.com/kb/ht3131
    – Reezy
    Apr 16, 2014 at 11:20
  • "For best results it is recommend that you put your computer to sleep before disconnecting your display."
    – Reezy
    Apr 16, 2014 at 11:28
  • I understand but on my MBA it is better to do it while awake ?
    – Ruskes
    Apr 16, 2014 at 11:36

1 Answer 1

1

Putting MBA in to Sleep mode will make it write a Sleep image, that is a file that contains your last settings ect.

Now when it wakes up it tries to load that file just to find out all is different now, no monitor ?

Then it goes in to switching the display modes that creates the flickering.

My advice, skip the Sleep mode and just open the clamshell, then turn off the monitor and unplug it.

3
  • I'll try this and see if it happens or doesn't happen again.
    – Reezy
    Apr 16, 2014 at 11:21
  • Seems like it works fine if I just open the lid and carry on.
    – Reezy
    Apr 17, 2014 at 7:28
  • 1
    Thank you for coming back to report the result and that you are a happy user now.
    – Ruskes
    Apr 17, 2014 at 8:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .