1

I just decided to dig out an old white mac book I have sitting around to poke around with. I'm fairly certain it is a lost cause, but I thought I'd see if anyone has any ideas.

So I can move the mouse around the screen, but I cannot click anything on the screen. Rebooting into Lion recovery I seem to be able to click, but I loose that as soon as I connect wifi.

Here's the kicker, using an external mouse I get the same behavior. I can move, but clicking does nothing.

I think it's hardware, but I don't think it's the trackpad.

Any ideas?

  • Have you run Apple Hardware Test? A swelling battery is one possible cause of mechanical issues (such as trackpad button stuck). That's not the only possibility though; I had trouble with a PowerBook that I repeatedly carried in backpacks that probably forced it to flex a bit every time. Might this be related to your case? – D A Vincent Apr 19 '14 at 7:48
1

It could also be the battery swelling and pushing the trackpad button from below. Try taking the battery out to see if that solves it.

Best, Teo

  • I should have made a note of this; I've actually seen this in my main pc, a 15" unibody, but not in a white macbook. In any case, I have removed the battery and checked this. Thanks for the suggestion though. – MattB Apr 16 '14 at 17:41
1

This was supposed to be a comment, but it turned out too long.

It might be that the trackpad is slightly damaged so that the button is somehow pressed down constantly.

I have a black macbook that clicks every time I rest my hands anywhere near the area below the keyboard or around the trackpad. The plastic around that part of the case has kind of caved in and it affects the trackpad. If something similar has happened to your macbook, only that it is constantly pressing the button, you wouldn't be able to press any buttons with any mouse.

On my own macbook, all of this (the case caving in) started after almost the entire bottom edge of the top case was breaking off, like in the picture below, which is a common problem on many of the macbooks (picture through google).

Macbook broken plastic edge

Disabling the internal trackpad while only using the keyboard

  • Open Spotlight. The keyboard shortcut for this is usually cmd+space.
  • Once in System Preferences you should be able to select "Accessibility" simply by starting to type it (or whatever it is called in the language on your macbook). Or you might have to press cmd+f first.
  • Navigate the Accessibility preference pane by shifting focus around to different tabs, buttons etc with combinations of tab and arrow keys.
    • When a checkbox is in focus, press space to check it.
  • The checkbox you are looking for is called something similar to Disable trackpad when external mouse is connected in the mouse and trackpad tab.
  • Interesting idea. I was kind of moving that direction late last night... only thing is that I'd hate to buy a new keyboard just to test it, and I'm having trouble navigating to the settings... I'll see what I can do with this. – MattB Apr 16 '14 at 12:55
  • @MattB I've updated my answer, hope that helps. – daniero Apr 16 '14 at 16:22
  • It does. I'll be trying that when I get home. I didn't know the shortcut keys. – MattB Apr 16 '14 at 17:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .