3

I have a copied music files to USD drive, but after copy/paste, the files are hidden. For example, in Finder:

Console:

enter image description here

And in hidden file there are a many attributes.

Example:

com.apple.quarantine^@^@^@^A^K^@^@^@�^@^@%com.apple.metadata:kMDItemWhereFroms^@0001;53419077;Google\x20Chrome;BFE9A983-768C-4B56-BC4F-1A2B69A72963bplist00�^A^B_^P9

How can I can a disable the hiding of files for coping/pasting files?

1
  • I am sure it is only me, but I have trouble understanding your question, I will edit it and you tell me if you do not like my edit.
    – Ruskes
    Apr 15 '14 at 17:06
2

These are AppleDouble files. As you discovered by opening them, they contain metadata for the files that you copied.

Since the disk is formatted as MS-DOS, OS X needs somewhere to store certain metadata for the file. This metadata is stored in an AppleDouble file. Such metadata includes Finder information and extended attributes.

These files begin with a dot, so are hidden. You shouldn't unhide these files, or modify them. You can remove AppleDouble files using dot_clean -m

3
  • Or use applications like CleanMyDrive to automatically delete these unwanted hidden files from non mac drives.
    – peterx
    Apr 15 '14 at 18:00
  • It is possible to completely disable this feature?
    – ZhukV
    Apr 16 '14 at 6:10
  • 1
    @ZhukV You can use BlueHarvest — it doesn't prevent their creation but automatically removes them. Note that you won't be able to store certain metadata.
    – grg
    Apr 16 '14 at 18:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .