8

I have OSX Server running on a mac mini in my home. I've been using it for doing Time Machine backups from my MacBook. This worked fine until I changed the password for my user account on the mac mini. At that point, backups on my laptop started failing, indicating that I needed to update the password that the laptop was storing for the mac mini. However, when I try to do so (at System Preferences > Time Machine > Select Backup Disk...), I get the following error:

"You do not have the necessary read, write and append privileges on the selected network backup disk."

The laptop is running OSX 10.9, and the mac mini is running OSX 10.8.

Has anyone using OSX Server for backups experienced something similar to this? Does anyone know how to fix it (without losing all of my previous backups)?

1
  • 1
    Seems this has broken again on Big Sur on an APFS backup volume. None of the solutions below seem to work.
    – balupton
    Dec 20, 2020 at 1:09

5 Answers 5

12

On my iMacs running macOS High Sierra (version 10.13.6) I had to explicitly add filesystem permissions for Time Machine to function correctly over the network. This resolved the You do not have the necessary read, write, and append privileges on the selected network backup disk error message.

I'm using username_A on both the source and destination iMacs.

On the source iMac, I used username_A when configuring Time Machine to run over the network to the shared network drive.

On the destination iMac (the one sharing out the Time Machine backup disk over my home network), I had to add username_A to the list of allowed users in System Preferences → Sharing → File Sharing. I also had to pull up the Get Info window for the shared disk and add username_A to the Sharing & Permissions list at the bottom of the window. Once I had added username_A in both places on the destination iMac, I was able to get Time Machine running over the network.

3
  • Same problem here. It was only when I added the permission to the shared folder from the Get Info window that it allowed the connection.
    – zkarj
    Feb 19, 2019 at 7:30
  • I only had to set permissions for Everyone to Read/Write in the Get Info Window. Feb 11, 2020 at 4:00
  • I, too, was missing the Get Info window change (macOS Catalina). Once I did that, TM started to work again. Thank you for this answer!
    – JVC
    Nov 13, 2021 at 19:59
1

I still don't know what caused the issue to come up in the first place, but I was able to get around it by going to Server.app > File Sharing > [my backup volume] > Edit Share Point... and then adding my user to the Access section of the page with Read & Write permissions.

I don't know how/why it worked before or why changing the user password caused it to stop working, but doing the above gets around the issue.

0

If you've previously connected to said network drive before and are having trouble reconnecting, it's possible, the folder where the time machine back-up resides is locked. I would try navigating to the network folder, look for "TimeMachineBackup" and if you see a locked logo on the folder, simply right click -> get info, and uncheck the locked box, then try initiating the time machine to use the network drive again.

0

The same error message occurred in my case. I have a Time Machine set up with netatalk. Initially, I had only one user, but later I added additional users and added them all to a timemachine group, with the single sparse bundles owned by the respective users. Even though a backup already existed and the user has full permissions on the sparse bundle, the Time Machine backup failed.

It turns out that the user also needs write access to the folder where the sparse bundle is located.

I can understand that this is required for an initial backup, where a sparse bundle is created (and renamed). However, the Time Machine client checks for the write permission even if the sparse bundle already exists.

0

tl;dr: make sure the user and group filesystem permissions (not just the Sharing permissions) are set for the user account that will be used to access the Time Machine disk over the network


My configuration includes a Mac Mini running macOS Catalina with an attached USB HDD, and a MacBook Air (among other MacBooks) running Monterey. I wanted to use the disk attached to the Mac Mini as the Time Machine disk for all systems on the network. I kept hitting permissions issues, including this one. The previous answers here such as the one by jefe2000 were not sufficient to resolve it.

The external disk was formatted as HFS+ (Journaled, Case Sensitive, Encrypted) and mounted by the Mac Mini.

The Mac Mini itself had Time Machine configured and working, backing up to the root of the external disk (/Volumes/ExternalHDD).

In my System Preferences > Sharing > File Sharing, I had to add a directory inside the external disk (e.g. /Volumes/ExternalHDD/RemoteBackups) as the shared folder. For this shared folder, I used the following settings

  • under "Options" (the button on the main File Sharing page) I enabled "Share files and folders using SMB" along with AFP (though I think only SMB ended up being used for this). I did not add any Windows File Sharing users.

  • For my RemoteBackups shared folder, under "Users" I added my Mac Mini's primary administrator account for Read & Write. I left System Administrators and System Group to the default (also read & write). I set "Everyone" to "No Access"

  • When you right-click on the shared folder, you get extra menus including "Advanced Options". For this, I selected "Share over SMB and AFP". I also selected "Share as a Time Machine backup destination"

This is roughly where other users' answers stop. However, it was not enough for me. I could see the Mac Mini's RemoteBackups shared Time Machine "disk" (really just a directory on a volume), but every time I tried to use it, I would get the same permissions errors.

To debug the situation on my MacBook, in Finder I went to Go > Connect to a Server and entered the address for my Mac Mini; smb://mymac.local. Use the Mac Mini's system admin account to log in, and you get a menu with shared volumes available. From here, I could see the RemoteBackups directory. But after opening it in Finder, I could not make any new Folders. Confusingly, if I did a "Get Info" on the RemoteBackups directory, at the bottom under Permissions it actually said that I had Read & Write access, but any write attempts or attempts to adjust permissions would get blocked with permissions errors.

This indicated to me that while I had the SMB and network sharing settings configured correctly, I was missing a critical piece: the permissions on the disk itself.

Back on the Mac Mini, I pulled up a terminal window and cd'd over to /Volumes and could see from ls -l that the the ExternalHDD disk had root ownership and wheel user group. The same was in effect for the RemoteBackups subdirectory located on that drive. This appears to be OK for processes running locally on the Mac Mini, but evidently not OK for remote access. I had to run chown -R myadminusername /Volumes/ExternalHDD/RemoteBackups to give the RemoteBackups dir ownership to my Mac Mini's local admin user account. For good measure, I also ran chmod -R ug+rw /Volumes/ExternalHDD/RemoteBackups to make sure everything had read write access under that directory tree.

Another measure I took was to dig through my Keychain app on the MacBook and delete any saved logins for my Mac Mini server, and for Time Machine. I also rebooted the MacBook and Mac Mini a couple times during this whole process for good measure to make sure all the updates were getting applied.

After all this, on my MacBook, I selected the Mac Mini's Time Machine disk RemoteBackups again (with encryption, logging in with the Mac Mini's admin account), and finally everything works.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .