5

My computer is behaving oddly and I would like to know if someone else has this issue too (if so, it's a bug) or that I am the only one (in which case there is probably a quick solution).

Let's say I have an application at full screen (Xcode) on my left monitor and I have the monitor on the right with a desktop view. I do something causing another application to activate (Run my iPhone app in the simulator).

This is what happens sometimes: the left monitor switches from the app to the desktop (I suppose to open the window there), but the window opens on the right (which was already on a desktop view).

I understand that the system might choose either monitor, but switching the one, while displaying the window on another? That's right out ridiculous!

If anyone has (had, hopefully) the same problem, please tell me how you fixed it or tell me I should stop wasting my time and start living with it.

EDIT:
I have tried unchecking "When switching to an application switch to a space", but this doesn't improve the situation. In my scenario (left full screen app, right desktop) it yields identical results.

In the following scenario it makes things even worse (from my POV). The left monitor (same as before, e.g. Xcode) shows a full screen app and the right one as well (e.g. Calendar). I do something in the left app that activates the iOS Simulator (or Finder or whatever really). The left monitor switches to an empty desktop. The right one doesn't change, but the just activated app (Finder or Simulator or whatever) does "appear" in a currently non-visible space in the group of spaces belonging to the right monitor.

PS.:
I have checked if any of the apps in question were assigned to a desktop, this was not the case.

  • 1
    I agree that sounds weird. But it wouldn't surprise me if it has a little something to do with Spaces. Try going to System Prefs -> Mission Control and uncheck "When switching to an application, switch...", and perhaps "Group windows by application", and make sure "Displays have separate Spaces" is checked. Then see if you can replicate the problem. Also, when Simulator is open, right click it on the dashboard and make sure it isn't assigned to any desktop. Let me know either way and I can make it into an answer if this the problem. – bassplayer7 Apr 15 '14 at 21:06
  • I unchecked "When switching to an application etc etc" to no avail. The simulator is NOT assigned to any desktop. Thanks for the suggestions, though. I have added the result of your suggestions to my question – pancake Apr 16 '14 at 6:35
  • 1
    See my problem below. Is this the same behavior you are describing? apple.stackexchange.com/questions/197339/… – lobi Jul 24 '15 at 22:37

You must log in to answer this question.

Browse other questions tagged .