2

When I copy some files/apps to my samba shares (1 running FreeBSD and the other is running Debian Linux), I get an error code -43.

this is the text of the error message

operation cannot be completed as one or more required items cannot be found

This doesn't happen to all apps. I've encountered the problem copying calibre/ripit/textwrangler and possibly more. But I didn't get the error copying Chrome/VNC viewer and possibly more as well.

I've searched the net and I found an Apple support article but I don't think it applies to me.

Any ideas on how this can be avoided or perhaps a workaround? At the moment, the only workaround I can think of is to tar my files first before copying to my network shares.

thanks very much for the help :)

update:

I tried copying the files using the cp command and I was getting "cannot copy extended attributes" error. After removing the extended attributes via

xattr -rc calibre.app

and confirming the extended attributes are gone by running

xattr calibre.app

and I am still getting the same error. I tried copying Google Chrome which I don't have any problem with copying using drag-and-drop and I get no errors at all.

2
  • Please post your smb.conf
    – duenni
    Apr 16, 2014 at 12:56
  • I had a similar situation - copying files between volumes and getting error -43 from the Finder. But it wasn't Samba shares, it was between partitions on one hard drive. The linked support article was very suggestive. After I renamed the target partition to another name, then back to the original name, the problem went away. Mar 8, 2016 at 7:49

0

Browse other questions tagged .