0

Obligatory system info: I have a late-2013 retina MBP 15" running OS X Mavericks 10.9.2 and Safari 7.0.3, although I've had this bug for years (I think), even on my previous Mac, whose data was migrated to the new Mac mentioned above.

There is an option in the context menu that shows up when one right-clicks a PDF open inline in Safari, which is supposed to be "Open in Preview.app". For a while this displayed "Open in Skim.app" on my Mac (which is another PDF viewing app I have installed), and more recently it has changed to "Open in Safari.app". Regardless of whether it shows Skim.app or Safari.app, clicking on it opens the PDF in Preview, which is what I wanted it to do anyway, so this is not harmful to my workflow. Still, it bothers me that it shows the name of one app (and in the case of Safari.app, one that doesn't even make sense) while opening another.

I tried logging on with the guest user on my computer to see if it is a problem with my user account. There, the context menu says "Open in Safari", without the .app suffix at the end. When clicking on that option, the PDF is opened in Preview.

Also, I still have access to my old computer, whose drive was wiped and the OS reinstalled. I just tried opening a PDF in it, and the context menu says "Open in Preview" as expected. So it's probably some kind of setting that has been changed on my installation, and survived even when I migrated my data from the old to the new computer.

Any ideas what I can do so that the context menu shows "Open in Preview"?

1

You could install Mavericks again via the AppStore. This does not affect your personal files, but it will replace the edits you've possibly made by factory default system files.

0

Before you go true major task like re-installing Mavericks try following:

  • Disable Safari extensions / Addons - and restart Safari after this action.

  • Use Terminal defaults write com.apple.Safari WebKitOmitPDFSupport -bool YES

  • Disable Open Safe files if it is checked:

Open safe files

None worked above then - Reset Safari to factory setting.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .