2

I have tried formatting and partitioning this brand new hard drive and it has failed on multiple computers using multiple methods. It is a LaCie Porsche Design 4TB hard drive.

Here is the commands I have been running:

$ diskutil list disk4
/dev/disk4
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *4.0 TB     disk4
   1:                        EFI EFI                     314.6 MB   disk4s1

$ sudo gpt -r show disk4
      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2          4         Pri GPT table
          6      76800      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
      76806  976677835
  976754641          4         Sec GPT table
  976754645          1         Sec GPT header
$ sudo fdisk /dev/disk4
Disk: /dev/disk4    geometry: 60800/255/63 [976754646 sectors]
Sector size: 4096 bytes
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
------------------------------------------------------------------------
 1: EE 1023 254  63 - 1023 254  63 [         1 -  976754645] <Unknown ID>
 2: 00    0   0   0 -    0   0   0 [         0 -          0] unused
 3: 00    0   0   0 -    0   0   0 [         0 -          0] unused
 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused
$ diskutil unmountDisk disk4
Unmount of all volumes on disk4 was successful
sudo gpt add -b 76806 -s 976415691 -t hfs disk4
disk4s2 added
$ diskutil list disk4
/dev/disk4
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *4.0 TB     disk4
   1:                        EFI EFI                     314.6 MB   disk4s1
   2:                  Apple_HFS                         4.0 TB     disk4s2
$ diskutil list
/dev/disk4
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *4.0 TB     disk4
   1:                        EFI EFI                     314.6 MB   disk4s1
   2:                  Apple_HFS                         4.0 TB     disk4s2

Then here is where it appears I have ran into trouble:

$ sudo newfs_hfs -v "4TB" -J /dev/rdisk4s2
newfs_hfs: WriteBuffer:  pwrite(3, 0x10dfba000, 131072, 450764800): Resource busy
newfs_hfs: write (sector 110050): Invalid argument

Any ideas of what I might be doing wrong or what I can do to fix it?

Many thanks!

  • this is impressive, what does teh disk utility say – Ruskes Apr 13 '14 at 21:56
  • "Disk Erase failed with the error: File system formatter failed." – lawdawg Apr 14 '14 at 1:02
0

Try to verify the HDD from disk utility and repair permission if this is doesn't work, try to format it using windows machine.

  • Tried all the above. Going to call the company and get a replacement. Thanks. – lawdawg Apr 14 '14 at 15:34
0

Sent in the HD. It was broken, but they replaced it, so these are evidently sometimes the sign of a broken HD.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .