0

I'm running Mavericks, and using Vagrant with VirtualBox to spin up a Precise32 box. When I first started, I had issues with apt-get update on the box (hash sum mismatches, etc.); so after weeks of trying to fix it, I just reinstalled my OS and tried again--problem solved. Unfortunately, the problem has returned after several months; so I cannot use the box anymore.

I have tried reinstalling Vagrant and tried deleting everything I could find that was associated with the box and re-adding the box; but nothing seems to work. I'm guessing that there has to be something that's being left over from the old box(es) (registry? I don't even know..), but I can't figure out what it is and how to remove it.

Thoughts? I just want to start with a totally fresh box without having to reinstall my OS.

Edit 1: I'm still looking into this, but this may be resulting from an internet filter that I installed (k9)--see here.

0

Mavericks has left me in tears, over a similar issue.

I upgraded to Mavs using appstore and, it went fine for a couple of weeks.

I think that the problem occured after I upgraded to the latest Virtualbox (I know nothing of Vagrant, Precise32, and I don't want to).

There came an occasion when I couldn't VBoxManage - restart. It shut down the VM but, would not and cannot restart the VM.

Right now, I'm trying to work out a way to brute force Mountain Lion to install over Mavericks. I'm completely out of other ideas, apart from to get a tattoo that reads, 'Don't upgrade, just because it's there - it will only cause you to cry in your beer'.

| improve this answer | |
0

I finally stumbled across this question/answer, which explains that having K9 Web Protection installed caused these issues; and I realized that it probably had some merit, since I had not installed K9 immediately after reinstalling my OS--hence the reason I had no issues for a while. So I believe the current workaround is to not run K9, which has its downsides, obviously. I installed OpenDNS on my router for home network filtering instead.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .