3

I distinctly remember that when I bought my first iPhone and iPad a couple of years back, I was able to install the CAcert root certificate on those devices and iOS would trust the certificate. These days, however, I can't get this to work anymore. Whenever I install the certificate, iOS always marks it as "not trusted". What is the reason for this? And even more importantly, how can I fix it?

The devices I am talking about are an iPad 2 (iOS 7), an iPhone 3GS (iOS 6) and an iPhone 4S (iOS 7).

4

It turns out that iOS 5 and newer no longer trust certificates that are signed with the MD5 hash algorithm. This is confirmed by the official Apple support document http://support.apple.com/kb/TS4133.

The current CAcert root certificate is signed with MD5, so there is no fix for the problem until CAcert issues a new root certificate.

  • Actually, only class 1 is signed with MD5. Class 3 isn't, it's SHA-256. Sign using class 3 and try to import class 3 to iOS. – Max Ried Apr 12 '14 at 11:16
  • @MaxRied I already tried, but no luck there, the class 3 certificate is marked as "not trusted" as well. It's only a guess, but I believe the probable reason here is that the class 3 cert is only an intermediate cert, but iOS wants to see the entire cert chain up to the root. – herzbube Apr 13 '14 at 23:39
  • 1
    OK, also tried to install both certificates at the same time by putting them into the same file. Did not work either. – Max Ried Apr 14 '14 at 10:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .