14

I really don't need my phone to buzz every time I get a text message, so I've done my best to turn off all of the vibrations associated with the Messages app. I have done the following:

  1. In Settings>Sounds>Text Tone I have set Vibration to None.
  2. In Settings>Notification Center>Messages>Alert Sound I have set Vibration to None

After setting both these settings, It's almost working exactly how I want it except for the one most annoying problem of all:

When I have the Messages app running and in the foreground and am in a conversation with someone, if that person replies to the conversation, my phone vibrates. If another person texts me and I do not have their conversation currently open, it does not vibrate!

This is literally the only time a text message will cause my phone to vibrate and it's the main reason that I wanted to turn off all text message vibrations in the first place! Why would I want it to vibrate when I'm currently looking at the conversation as the text comes in?

Does anyone know what combination of settings I can set to achieve what I'm trying for? I just don't want any text message or iMessage to ever vibrate my phone.

I've read both this question and this question which seem related but out of date.

  • 3
    There isn't a way to do it with the standard iOS settings. I would recommend that you take this to /r/jailbreak on Reddit and suggest this as a tweak on this thread here. It's an easy enough tweak to make, and I'm sure that a lot of people would use it (I'd even have my team develop it if we had the time). – Andrew Larsson Apr 18 '14 at 2:47
1

You can make the LED flash instead of Vibrate when you have notifications.

Go to Settings > General > Accessibility and scroll down to 'Hearing' where 'LED Flash for Alerts' resides.

led flash

  • Unfortunately, that doesn't turn off vibration. – Brian Apr 24 '14 at 20:05
  • How come? is it flashing and vibrating now? – Ruskes Apr 24 '14 at 20:20
  • Yeah, it just does both. – Brian Apr 24 '14 at 23:30
  • It should not, but did you restart after changing the setting? If it still does not work, use the customize Vibrate and make it one short one. – Ruskes Apr 24 '14 at 23:58
1

Just go to the search box right when you get into settings and type "vib". "Vibrations" will come up and the first one that u see with the picture of the settings on the left hand side of that line, the first one that says vibrations, and turn it off. If it's green, touch it for it to become grey and turn it off, this is for the iPhone, I don't know about other phones.

-1

I played with my settings and did some testing with a friend and I think I found a solution. I did steps 1 and 2 like you did, but I also turned down the volume of the alert down to about 10%. After I did your first 2 steps I thought it was still vibrating, but as it turns out, the speakers are so good that the alert sound makes it feel like it is vibrating.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .