6

I am on a clean Mac OS X 10.6.8 machine (I erased the hard drive and reinstalled the OS yesterday). I do have to re-download a few apps, and Xcode happened to be one of the first.
I completed the configuration and it started the actual installing . It said 'estimated time: 1 hour' but when I checked after twenty minutes it was almost ready, though it had stopped. I was greeted with this:

What I found

OK, an informative error message. Just close iTunes and complete the installation, right? Wrong, iTunes wasn't running. (I do know the difference between closing a window and quitting an app.) So I tried opening and quitting iTunes, but that didn't work either. Then I had a look at the Activity Monitor, but I couldn't find a process from iTunes. What do I do now? Even the buttons to cancel the installation are greyed out, so I don't even know how to retry the installation.

PS: Clicking on the find symbol next to iTunes in the alert screen just starts iTunes.

Update

I found a process called 'iTunes Helper'. I assume that's what's causing the alert. Is it safe to just kill this process?

And I found this: http://osxdaily.com/2011/08/02/cant-install-xcode-because-itunes-fix/! That fixes it, restarting the computer will relaunch iTunesHelper. That should have fixed it, according to the linked article, but sadly, I still have the alert opened, the installation doesn't progress.

  • Feel free to self-answer :) – grg Apr 11 '14 at 15:23
  • The process 'iTunes Helper' exists to automatically open iTunes when an iDevice is plugged in. It should be safe it kill it. Not sure it will help tho. – AllInOne Apr 11 '14 at 15:24
  • I really was convinced that would help, this osxdaily article said so. But sadly, it didn't. @grgarside – 11684 Apr 11 '14 at 15:28
  • Is there a reason you can't run Xcode 4.2? It is generally best to run the latest version of Xcode that an OS supports and once you get used to it it is much nicer than Xcode 3. – Ɱark Ƭ Apr 11 '14 at 15:50
  • @Mark Actually you are the second person suggesting that. Last time I looked it up I found you need Lion for XCode 4. But I'll look it up again, because wishful thinking. – 11684 Apr 11 '14 at 15:53
4

OK, I solved it. So I first found this article, which said to killall iTunesHelper. That didn't work. After that I found an Apple discussions thread on this where someone had to killall AlertAll (the process responsible for the Install Alert). I did that and the installation finished succesfully.

Step-by-step

  • Go through the installation and get this alert
  • Open Terminal and execute killall iTunesHelper (or kill it with Activity Monitor)
  • Execute killall AlertAll if the installation still doesn't proceed (Caution: after this the installer assumes iTunes is completely stopped. If it's not, things can of course go wrong. So better look over your processes list twice before doing this.)
  • Everything should be fine

This was exactly what I did, if it doesn't work for you: I'm sorry, but then your issue is different and you should ask a new question.

  • When I went into the activity monitor, I couldn't find killall but I did find alertall and forcing this program to stop fixed the problem. I hope this helps people who cannot find killall in the activity monitor. Best Rgds – user177776 Mar 31 '16 at 14:22
  • @mbodnar3 killall shouldn't be in Activity Monitor, it is the command you can execute within Terminal to achieve the same result as killing a process with Activity Monitor. I basically gave two ways of doing the same thing. – 11684 Mar 31 '16 at 23:01

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .