I don't want to use my trackpad too much due to a strain injury, hence I use the Control F2 "Move Focus to Menu Bar" a lot.

However this feature only works occasionally, it can work for hours and then suddenly stop working, sometimes I can fix in the Keyboard Shortcuts pref pane by unchecking and checking the "Move Focus to Menu Bar" checkbox, at other times it takes a restart of the system.

enter image description here

I'm a big Apple fan-boy, and I always marvel at the cool features in OSX, this is the first time I have a Windows-esque experience with the OSX UI :(


When you're sure you've got your Fn key settings the way you want them and it STILL doesn't work:

My solution:

  1. Go back into Preferences > Keyboard > Keyboard Shortcuts pane.

  2. For the item "Move focus to the menu bar", assign a DIFFERENT function key, other than F2. (Something you're not using, like, say...^F9...or whatever.)

  3. Now use THAT key instead.

Sounds kind of nuts, I know. And it's annoying to use a different key. But I've found that ^F2 just won't consistently work after I've been using enough 3rd party programs, particularly if they're complex. Sometimes ^F3 will also fail, and that keyboard pane can start acting a little strange on its own to be honest. This does seem to work though.


  • That seems to work! You're lifesaver, thx a bunch :) – timkl Apr 27 '11 at 7:28
  • Well, some time have past and I have the exactly same problem with this approach :( – timkl Apr 30 '11 at 17:41
  • 2
    My experience: after if fails with the "new" key mapping, switch it back to the original one, and it typically starts working again. Then I toggle between these two mappings to make it work when one (mapping) starts failing. Which is unfortunately often. – Johnny Utahh Jan 4 '15 at 20:03
  • 4
    What an absolute disaster! I'm still seeing this issue on Yosemite. – Srikanth Jun 23 '15 at 14:37
  • I noticed "Move focus to the menu bar" got turned off for some reason after upgrading from El Capitan (10.11) to Sierra (10.12) – William Turrell Sep 28 '17 at 8:07
  • I've had the same struggle with keyboard shortcuts to the menu bar (tried many different combinations).

the only one that has consistently worked is the help shortcut ⇧ ⌘ ? (shift+command+/)

from the help menu just use the arrows to navigate to file/edit/view…

  • 4
    This works, plus you can just type the command you want to find immediately. – justingordon Jun 7 '13 at 23:56

Same here: ^F2 almost never works
Workaround that works for me (without assigning new shortcut): press ^F3 and then immediately ^F2

  • I've solved this problem by mapping a keycombo with Keyboard Maestro to simulate pressing the Apple icon in the upper left corner of the screen. – timkl Mar 5 '12 at 19:13

I asked a question in the following link and got a hint to answer your question:


What I do is as follows:

  1. create an .app using Automator using the scrip in the above link,
  2. create a hot key for the .app,
  3. create a key stroke linked to the hot key (using KeyRemap4MacBook in my case).

It works great for me at least.

  • Or see this question for other ways to assign shortcuts to scripts. Automator applications have a maybe 100-500 ms delay at the start. – Lri May 6 '13 at 12:47

You must log in to answer this question.

protected by nohillside Nov 4 '13 at 4:35

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .