I have an Exchange account set up in Apple Mail. When I click the "Get new messages" button it successfully retrieves mail from the Exchange server.

I have the "Check for new messages" setting in Mail to "Automatically" but it is not retrieving them automatically, I have to manually click the "Get new messages" button again to get the messages.

I have also tried setting "Check for new messages" to "Every minute" but this does not work either.

Initially restarting Mail seems to fix this, but the problem seems to re-occur every time I wake up my computer from sleep/hibernation. I don't want to have to restart Mail every time I do this.

Is there a known fix for this behaviour?

  • Turn on the activity monitor see what is it doing.
    – Ruskes
    Apr 11, 2014 at 9:51
  • It is not doing anything. I changed the settings to "Every minute" and watched the activity window for a minute and nothing happened. Apr 11, 2014 at 10:35
  • 2
    Try restarting mail after you made the change, I just tried the 1 minute and it does it.
    – Ruskes
    Apr 11, 2014 at 10:48
  • Facepalm That does appear to have fixed it. I can't believe I didn't try turning it off and on again. Thanks. Apr 11, 2014 at 14:16
  • I noticed you removed the check mark for answer completed to you original question!, since now you have a new problem. I suggest you ask new question rather then trying to resolve it as comment, or modifying you question at some later time.
    – Ruskes
    Apr 23, 2014 at 13:04

4 Answers 4


After changing the Check for New Messages delivery settings you need to restart the Mail for it to take an effect.

  • Now I'm having the problem where the symptoms reappear after the computer has been sleeping/hibernating, and I don't really want to have to restart Mail every time. Any suggestions? Apr 16, 2014 at 8:54
  • I noticed you removed the check mark for answer completed, since now you have a new problem. I suggest you ask new question rather then trying to resolve it as comment.
    – Ruskes
    Apr 23, 2014 at 13:02
  • Originally it did not work at all!, now it works but you have a new problem of mail not saving the preferences. So your new question should be why is Mail not saving the preferences.
    – Ruskes
    Apr 23, 2014 at 13:09
  • No, the problem is not Mail not saving the preferences. The problem is mail not checking for e-mails as per the description. The preferences are preserved between launches of Mail. Apr 23, 2014 at 13:10
  • This doesn't work. It might appear to fix the problem immediately, but it's no different than forcing a connection.
    – joemaller
    Sep 24, 2014 at 11:54

If your Mac is running 10.9.x, Apple has posted a Knowledge Base article about this issue. There's no fix, but Apple has a manual workaround included in the Kbase article:


Quitting and reopening Mail forces it to re-establish a connection to the email server. You can use these steps to receive new mail messages without quitting Mail:

Choose Mailbox > Take All Accounts Offline.

Choose Mailbox > Get All New Mail.

As a shortcut, you can also add the Take All Accounts Offline and Get Mail buttons to your Mail toolbar.

Choose View > Customize Toolbar.

Drag the Take All Accounts Offline button to the Toolbar if it is not there already.

Drag the Get Mail button to the Toolbar if it is not there already.

Click Done

To receive new mail messages, click the Take Offline button, then click the Check Mail button.

OS X: New email messages not received until Mail is quit and reopened

  • That is not the same issue. I can get new mail by clicking the "Check Mail" button without doing any of these steps. Apr 11, 2014 at 11:49

I've seen similar issues with Outlook on Windows. Rebuilding or recreating a user profile will sometimes fix it. According to Apple support, here's how to do a rebuild for Mail in OS X Mavericks and what it accomplishes:


You might need to rebuild a mailbox to update the list of messages it contains. For example, if messages appear to be missing or garbled, or if you can’t find all relevant messages when you search using Entire Message.

Select a mailbox, then choose Mailbox > Rebuild. When you rebuild mailboxes for IMAP and Exchange accounts, locally stored messages and attachments are discarded, and the messages and attachments are downloaded again from the server to your Mac. Your mailbox appears empty until the download is complete.

Last Modified: Nov 6, 2013.


I have two IMAP accounts and after opening Mail, it would take minutes to have new mail come in. If I hit the get new mail button, it would still take many many seconds to have mail appear.

Per the thread, I went to Mail prefs and toggled from AUTO to 1 minute. Quit Mail. Launch again and revert back to AUTO and quit Mail.

Upon sending a test email to myself, things seem to be back to normal. I will report again should things change.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .