0

My mac mini from the 2011 refused to boot. Apple logo and loading image forever..

I tried cmd+s: Went through all the steps from the applejack, tried fsck -fy, all semmed pok,

Tried cmd+v: It wouldn't fully load, got the error Disk02 I/O error (it was the original 1TB disk with two partitions),

So I thought the HD must be done, so I bought one Samsung SSD HD 120GB Sata 3,

Same result.

Thing is that I tried with both drives to install again the mac os x vía USB (I don't have a CD drive) and in both cases I came up with the tipical 'you must reboot your computer' error scereen.

So With the new HD replacing I did same steps, cmd+s and cmd+v provided same results....

Any thoughts?

2 Answers 2

2

First I would try doing the NVRAM reset by restarting and holding down Command-Option-P-R until you hear the startup sound a second time. Then I would try an SMC reset. Mavericks and Mountain Lion can be pretty finicky and even strange when new hardware is installed. I've had to reset the SMC on my system with Mavericks 3 times since I started using Mavericks. In my case, it's Mavericks, not the hardware. It's buggy.

The I/O error typically is either a bad drive or cable, so you probably did have a real hardware problem at some point. I'd be inclined to recommend Scannerz (http://scsc-online.com/Scannerz.html) to test it, but you need a working system to use it, and if you can't even get yours to boot, that obviously won't help.

Does the Mac Mini even have a SATA cable to the HD, or is it a connector that sits on the logic board with the HD plugging directly into it?

0

I have Scannerz and it's an impressive tool, but like the other guy posted, I don't know if it would do you much good if your system won't boot.

SATA cables can go bad and often do, but unfortunately you can also have connector problems and even cracked logic board traces that will also produce I/O errors. The OS can't distinguish between an I/O error created by a bad block or sector and that caused by cables, connectors, or cracked traces. Scannerz comes with a tool called Phoenix in the package that can extract the OS on a volume to an external drive or USB flash and then use it to diagnose a problem, but once again, in order to have an e-boot volume like that you first need to make it from a working system. I think their assumption is that you'll use their Phoenix tool to start a test regiment before problems develop. People really should do tests on drives once in a while, unless you really like getting stuck without warning.

What I would do instead is put the SSD into an inexpensive USB enclosure and try to install the OS onto that. If all is good, it should work. If it doesn't work then you've got other problems. I say to put the SSD into the enclosure because it's brand new and it should be good. If it works you could try the same with the HD and see if there are problems. I suspect the SSD is either OK or you have really, really bad luck, which is unlikely.

Assuming the unit will boot off an external drive, how you want to proceed is up to you. If your Mac Mini is like mine the cable isn't much but it's there. You could try testing of some sort with the external as a boot drive and the internal as the test drive. I wouldn't be surprised if the problem is the cable if your unit has one, but if it's the connector or a logic board trace on the logic board, you probably need to get used to the idea of using an external drive.

An external SSD, even though it's bottlenecked by the data rates of USB or Firewire ports will still be faster than a regular HD, but it won't be as quick as one using a SATA port. They're lighting quick!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .