2

Since I've left Chrome as my main browser, every time I use it as secondary browser, Chrome enters in an eternal loop requesting my password to access each keychain bundle of my system. No matter how many times I click "cancel" it just keeps asking access to my passwords.

Is it possible to just make Google Chrome stop asking for my keychain? Once this start, browsing is not possible. The whole window is blocked with the repeated pop ups.

3

You mac has saved Chrome passwords in the key chain.

Open your key chain and sort by typing the name Google in search window so you can do the following easier.

This is what it looks like on my MBA.

Google passwords

Click on the first one of the Google password and then open the

access control tab

Set to

allow all applications to use

If you are not confident with that setting then use the + and add the Safari browser in to the allowed list.

Always Allow Access by these application

enter image description here

  • I have this problem, but this answer has not helped me at all, as nothing comes up when I filter to "google" for my keychain. And Chrome is set to be my primary browser. – Alison R. May 13 '14 at 15:06
  • @AlisonR. please post your problem as new question. – Ruskes May 13 '14 at 17:28
2

There is no way to make Chrome stop doing this... it's truly frustrating... I use 4 web browsers every day in web development. Safari is the only browser I allow. All of the "solutions" I have read over the past year is to either allow Chrome access or else delete the entries in Keychain... both solutions are useless to me. There should be an option in Chrome settings to STOP chrome from asking...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .