6

I use Mail.app with FastMail. Mostly, it just works.

However, when I start up Mail it never shows the Archive folder. The Archive button will move mail to it, but it's not there. The Goto mailbox menu item is greyed out for Archive in the Mailbox menu too. (cmd-2)

I can right-click on another folder, all of which show up, and choose "Get Account Info" then it scans all the folders, shows Archive which I double-click to open, and use that window, closing the original Mail window. All works fine and dandy. It's an annoying little dance I don't want to have to do.

Worth noting that once I've done the dance, then the cmd-2 short-cut works and the menu item above works fine.

In FastMail the Archive folder is configured to be displayed. It's set to Always Show.

This is on 10.9.2.

Using another mail client (Airmail, or Postbox) I didn't see this problem, but I like Mail.

10

I just had this problem on OS 10.10 (Yosemite). Here's how I solved it:

  1. Select the inbox.
  2. Right-click "Account Info"
  3. Select "Messages on Server" tab.
  4. Wait until the size of all of your mailboxes is calculated.
  5. Select the Archive mailbox and click "Show Messages" button.

The archive now appears in the mailboxes bar.

1

It appears that this is linked to Spotlight in some way.

I recently turned spotlight indexing back on for the volume holding my $HOME and immediately this started working again.

I assume that without the spotlight index it can't find the Archive directly automatically, then finds it via IMAP when I run through the steps in the question.

0

Once you have done the steps described above then ...

  1. View - show the Mailbox List,
  2. View - show the Favorites Bar,
  3. Click and hold the Archive Mailbox in the Mailbox List and drag it to the Favorites Bar.

Once you have done that the Archive Mailbox will always display in both the Mailbox List and the Favorites Bar.

  • Clever idea, but I already tried it. Yes, Archive is in my favs list, but it's greyed out until I do the steps in the question, after which, the fav works. – Alex May 11 '14 at 2:22
0

I'm not sure that this is an ideal solution for everyone, but I noticed that you can create a Smart Folder that links to an Exchange Archive with the following rule:

Message is in mailbox: Archive -> Exchange

When you create a new Smart Folder and select the "Message is in mailbox:" rule, it will show you a list of mailboxes in a drop-down menu which includes the Archive mailboxes linked to the accounts you have setup. The Archive option should appear as the last entry in the top section of the drop-down list, and if you then hover over the Archive entry, you should get another popup menu that will show your Exchange archive folder (it may be named something other than "Exchange" if you have given your Exchange account a different label in your Mail Account settings).

Once you have setup the new Smart Folder you should be able to see your archived Exchange messages within it. You can also drag the Smart Folder to the Favorites Bar to access it quickly that way, and you can also restrict searches to your archive if you wish when running a search by selecting it from the Favorites Bar.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .