I changed the home user name using http://support.apple.com/kb/ht1428 and now search in Mail and Finder only show me files I've accessed since the change. This is a major issue for me.

How can I fix this OR revert back safely?

I use Time Machine but my attempt to restore to the time before I made the change did not work.

  • Just to be clear, did you change the account name, the user folder name or both? – Mr Rabbit Apr 10 '14 at 15:40
  • It's been a few days so what I can say for sure is that I followed the guide above. – Ray Apr 10 '14 at 18:00

Go to Macintosh HD< Users< you should find your account name here < desktop< right click get info< give your self permission then apply this permission to all encloused items>

  • I'd tried the above but when I go to mail - search I still only get mail I've opened since I made the change in the results list, same with finder. Is there possibly an index file or something that needs to be deleted or re-indexed. Idk - it's a stretch but I'm really at a loss... – Ray Apr 10 '14 at 17:27
  • Try to re index the HDD, this could be done if you go to Apple< system prefrences< spotlight< privacy> then, drag the HDD from desktop and then drag it out, this will trigger the re indexing for your hard drive. – Wassimfr Apr 11 '14 at 6:56
  • I'm sorry I don't understand "drag the HDD from the desktop" drag it to where? Thanks. – Ray Apr 12 '14 at 5:03
  • forget about the drag in and drage out. all what you have to do in spotlight< privacy > tab is to add your hdd then remove it and this will trigger the re indexing – Wassimfr Apr 12 '14 at 23:33
  • Ding ding ding winner winner! Thank you! Worked for both finder and mail. Happy camper, thanks again. – Ray Apr 13 '14 at 4:50

Make sure that all the permissions are correct on your home folder.
You can use the ACL tool on the Recovery HD to do this:

  1. Boot into the Recovery HD using ⌘R.
  2. Run resetpassword in Terminal (available from Utilities → Terminal).
  3. Select your account from the drop-down list.
  4. Click the Reset button for Reset Home Directory Permissions and ACLs.
  • I've tried to do this a few times but the command doesn't boot me into Recovery HD or at least when I go to terminal and type in resetpassword the command isn't recognized...? – Ray Apr 11 '14 at 2:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .