4

My iPad 3 is set to use English as the main language for everything in the settings (International and Keyboard settings).

When I download an app, it's very often in the Russian language (when there's a translation available). And I don't know why. I don't even understand their alphabet so the apps are very unusable.

I already checked my AppStore account - but it's in Czech (that's where I live), which has got a classic alphabet.

Sorry about my English, I'm not a native speaker.

6

I just had the same problem and I solved it. My iPhone apps were very often in German but my iPhone was in Swedish. The problem is: I believe that your iPad's secondary language is set to Russian (Apps display in the first language they find on your list for which they have a localization included). So I believe that if you change your secondary language you should have apps in your desired language. To change secondary language, go to Settings > General > International > Language and choose whatever language you want (presumably English in your case) as secondary language. Then, when the language is set, switch back to your original language and you shall be all set.

  • On iOS12 I could choose to keep my primary language. But I also had to do "Change" on that screen to get at the ordering/remove list to get rid of my unwanted Russian. – thoni56 Nov 19 '18 at 18:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .