2

I'm trying to download and install Command Line Tools for my Mac through Xcode, but it is not in the downloads section like youtube videos tell me to go. So, I manually download it and install it, and it still does not show up. I need this so I can download MacPorts. Any suggestions on how to get it? Or how to see if I already have it? Thanks!

1

Run xcode-select --install

This will prompt you to download and install the CLTs using softwareupdate.

  • When I do that, I get a dialog box that comes up and says "Cant install the software because it is not currently available from the Software Update server – rhefley Apr 9 '14 at 16:18
  • @user38508 Do you have a custom software update server set? Is the machine under MDM? Is your account a network account through OS X Server? Try resetting your softwareupdate server: sudo defaults delete /Library/Preferences/com.apple.SoftwareUpdate CatalogURL – grg Apr 9 '14 at 16:20
  • To be honest, I have no idea what any of that means. lol. I'm a Mac Noob. I know the ins and out of windows because that is what I grew up on and have developed on. But I have recently switched over to Mac, and have no idea what anything is. lol – rhefley Apr 9 '14 at 16:22
  • @user38508 Then your answer is probably no :) Try the reset command to reset the server address to make sure it really is calling Apple. – grg Apr 9 '14 at 16:23
  • Ugh. One problem after another. Hopefully we can get this worked out. When I run the reset command, it says this: "Domain (/Library/Preferences/com.apple.SoftwareUpdate) not found. Defaults have not been changed." – rhefley Apr 9 '14 at 16:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .