2

Running 10.9.2, I have gone in to SysPrefs and made sure Keyboard>Text is set to NOT auto-correct, I have gone to Mail Prefs and made sure spell checking is done after I finish, but no matter what I try, I can type a valid word (I do have to use some science words, and of course company and personal names) and auto-correct changes them to some crazy "corrected" word in a flash! I have to delete and try again, sometimes it works, more often it gets replaced again! This is annoying.

I saw another question with an answer that told of an overlay showing the original word and how to use arrow keys and enter to replace what was correctly written in the first place; that did not work in my test on an email messsage. Just as a test here (Safari browser), I wrote "c o o l g o n i a n" but without spaces) and it is turned into "Colonna", capped and everything!

What might I be missing? I wondered if there is a plist file I might remove to re-do a prefs for the Mac?

CLARIFYING: While I appreciate the info on turning off spell-check in browsers, I guess I failed to state that this is a system-wide problem, not just in email or browsers. If I write that cool word in Adobe Illustrator, it also changes it to Colonna. So I guess I'm stuck with it, but it makes me nuts trying to enter words "correctly" that get corrected as soon as I hit the space bar!

  • I am not able to repeat this issue on my computer, i.e. I can type colgonian and I only get a red underline in various apps. The only place I can think of setting is the one I think you mentioned: "Correct Spelling Automatically" should be unchecked in Keyboard>Text (Additionally, there should be no entry for colgonian in the list of text replacements in that same place) – dwightk Apr 10 '14 at 18:05
1

Apple has multiple spelling and dictionary pre-installed.

Many application used them.

You will need to turn of spelling in each application you do not want to use it.

Usually it is simple by right clicking on the misspelled word and disable the spelling in that pop up for Safari, Firefox, Chrome ect. Also every application (word processing) has a menu setting to turn off spelling.

I prefer the way of adding my unique words to custom dictionary.

Example for Firefox

firefox dictionary

In Chrome is bit different it is called LEARN!

Chrome learn

  • I may be falling behind! I have never had a "right-click" mouse. In fact I no longer use a mouse at all, trackpad all the way. – user3314255 Apr 8 '14 at 19:14
  • I am with you, do not have a mouse, have a trackpad, The right click on track pad is two fingers click :) – Ruskes Apr 8 '14 at 19:17
  • ...Nuts! I hit return and it posted! So I have had this ame correction (the cool-gonian" thing replace in any place I try it (including here). I thought opt-clicking was a substitute for right-clicking but it gives me no way to diable anything--since it isn't even supposed to be enabled in any part of my Mac! And this also happens in Chrome. So I'm still fighting it. – user3314255 Apr 8 '14 at 19:19
  • sorry, that is not how it works, most applications have they custom dictionary where you add words to it, but unfortunate they do not share it with other applications. So if you save a word in the custom dictionary of lets say Firefox, it will not be shared with Chrome, so you have to do the same in Chrome. – Ruskes Apr 8 '14 at 19:32
  • @user3314255 with trackpad it is two fingers click = right click – Ruskes Sep 3 '18 at 22:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .