2

I used MacPorts to install bash (bash @4.3.8_0). I switched Terminal to use /opt/local/bin/bash as the command to startup.

However, now when I type vim ~/.<tab><tab>, it no longer lists dot files. If I switch back to using the default Mac OS X shell command, it works by listing the hidden dot files.

Does anyone know what settings I need to switch?

I've tried adding set match-hidden-files on in my ~/.inputrc as well as running shopt -s dotglob but neither seem to have any effect.

1

There is an issue filed for this in MacPorts Trac. The real issue is that auto completion does not work for any paths starting with ~ (tilde) — try vim .<tab><tab>.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .